2GN.ORG 2GN.ORG
The best source for the Second Generation Neon - Period.
 
 Watched TopicsWatched Topics   FAQFAQ   RulesBoard Rules   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks  :: Register
 ProfileProfile   GarageGarage   1/4 Mile Table1/4 Mile Table   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Screeching under throttle


 
Post new topic   Reply to topic    2GN.ORG Forum Index -> Naturally Aspirated
View previous topic :: View next topic  
Author Message
bshenanagins
n00b


Age: 26
Joined: 05 Feb 2015
Posts: 11




Post: #1   PostPosted: Mon Jun 29, 2015 10:24 am    Post subject: Screeching under throttle Reply with quote

Recently I've been hearing this screeching noise which I thought was my belts, seems to be coming from my intake. When the throttle plate opens I can hear this screech which eventually disappears when the plate fully opens. It is extremely annoying and I can't figure out where exactly it's coming from. It's coming from the plate or back because I took off my K&N setup and I still heard the noise. Any ideas?
Back to top
View user's profile Send private message  
occasional demons
Mr One World
Moderator


Age: 51
Joined: 03 May 2007
Posts: 19780
Location: Ashland, Ohio

2001 Dodge Neon ES

Post: #2   PostPosted: Mon Jun 29, 2015 6:54 pm    Post subject: Reply with quote

Is it a stock throttle body?

The Jeep TB's will whistle when they are bored out to a true 60mm. But that is usually just the first bit of throttle opening.

Possibly the TB needs cleaned. Enough gunk in the IAC passage might create a whistle effect, like blowing across a bottle's neck.

Another slight possibility is there small vacuum leak that is creating the sound as air passes by the surfaces of the leak. At WOT there is very little manifold vacuum, so that would explain why it diminishes the more the throttle is open.

It could also be the PCV valve, or the air make up tube to the back of the valve cover being restricted somehow.
_________________
Bill


2001 neon ES MTX with '02 R/T PCM
1999 neon 2.4 EDZ MTX
Help support 2GN!
Back to top
View user's profile Send private message AIM Address
Donkeypuncher
2GN Registrant


Age: 36
Joined: 12 Mar 2008
Posts: 2215
Location: Dallas, Tx

2002 Dodge Neon ES

Post: #3   PostPosted: Mon Jun 29, 2015 8:04 pm    Post subject: Reply with quote

I know my TB has a slight whistle at part throttle, you're probably hearing the same thing.
Back to top
View user's profile Send private message  
bshenanagins
n00b


Age: 26
Joined: 05 Feb 2015
Posts: 11




Post: #4   PostPosted: Thu Jul 02, 2015 12:34 pm    Post subject: Reply with quote

Thanks for the replies. I used to only just hear the whooshing sound from the intake which I liked but this irritating screech is something that has only gotten worse. I was thinking it was some sort of leak as well. In addition to this my acceleration has been pretty awful. Off the line it will not jump like it used to, it's very sluggish and it's as if the engine is trying to catch up with my accelerator. I thought it was my oil covered plugs which I changed this morning along with the valve cover gasket and the spark plug tube seals. I didn't notice much of a difference. When I accelerate the intake has a very deep tone and it sounds like it's struggling until the engine finally catches up with my pedal and then accelerates. I don't want to keep throwing parts at it, my guesses are coil pack and wires, fuel pump, intake leak. Any ideas? Would a leak in the intake cause such a drastic bog like that?
Back to top
View user's profile Send private message  
NickKo
2009 Gold Contributor


Age: 52
Joined: 11 Jun 2006
Posts: 2421
Location: IL./WI.border



Post: #5   PostPosted: Thu Jul 02, 2015 6:12 pm    Post subject: Reply with quote

bshenanagins wrote:
Thanks for the replies. I used to only just hear the whooshing sound from the intake which I liked but this irritating screech is something that has only gotten worse. I was thinking it was some sort of leak as well. In addition to this my acceleration has been pretty awful. Off the line it will not jump like it used to, it's very sluggish and it's as if the engine is trying to catch up with my accelerator. I thought it was my oil covered plugs which I changed this morning along with the valve cover gasket and the spark plug tube seals. I didn't notice much of a difference. When I accelerate the intake has a very deep tone and it sounds like it's struggling until the engine finally catches up with my pedal and then accelerates. I don't want to keep throwing parts at it, my guesses are coil pack and wires, fuel pump, intake leak. Any ideas? Would a leak in the intake cause such a drastic bog like that?


Are you still running the factory 'bellows' tube ?? Think (The one attaching the throttle body to the intake manifold)
I have read of one user on this board, who's bellows 'collapsed' internally -- And blocking airflow.


- Nick
_________________
-1998 2-dr SOHC MTX= 57mm TB; Maddog STS
-1999 4-dr DOHC ATX= UDP, Kirk Intake
-2000 Ply.LX with MTX = Maddog STS; CAI; 2.5 in. exhaust
-2001 Ddg. ES with ATX = UDP and Magnum header...Syked PCM 'pending'.

Official "I'm Going to Drive My Neon till it Dies" Club #000009
Back to top
View user's profile Send private message Send e-mail MSN Messenger AIM Address Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    2GN.ORG Forum Index -> Naturally Aspirated All times are UTC - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B © 2001, 2005 p h p B B Group
2GN.org Decals
MidwestNeons.com