2GN.ORG 2GN.ORG
The best source for the Second Generation Neon - Period.
 
 Watched TopicsWatched Topics   FAQFAQ   RulesBoard Rules   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   LinksLinks  :: Register
 ProfileProfile   GarageGarage   1/4 Mile Table1/4 Mile Table   Log in to check your private messagesLog in to check your private messages   Log inLog in 

AC Compressor cycling on/off every few seconds


 
Post new topic   Reply to topic    2GN.ORG Forum Index -> General 2nd Gen Discussion
View previous topic :: View next topic  
Author Message
gcretro
04Neon_SE
2GN Registrant


Age: 40
Joined: 25 Jan 2011
Posts: 331




Post: #1   PostPosted: Sun Nov 05, 2017 8:02 pm    Post subject: AC Compressor cycling on/off every few seconds Reply with quote

2004 Neon SE. 155k miles.

Of late when put to defrost, the fogginess wasn't going. (AC did seem to work in the summer). When in defrost (or even just AC on), the AC compressor cycles constantly every 3 seconds. (Radiator fan comes on, blower inside the car works fine, I can turn the compressor by hand.. etc.)

What could be the problem? I haven't checked the refrigerant level yet.

I figure I'll get one of those DIY recharge kits with a gauge and see if it's low... for starers. (I stay away from kits without leak sealers)

Thoughts?
Back to top
View user's profile Send private message  
occasional demons
Mr One World
Moderator


Age: 52
Joined: 03 May 2007
Posts: 19834
Location: Ashland, Ohio

2001 Dodge Neon ES

Post: #2   PostPosted: Mon Nov 06, 2017 4:47 am    Post subject: Reply with quote

My guess is it's low.

Does it only do this at idle, or also when driving?
_________________
Bill


2001 neon ES MTX with '02 R/T PCM
1999 neon 2.4 EDZ MTX
Help support 2GN!
Back to top
View user's profile Send private message AIM Address
gcretro
04Neon_SE
2GN Registrant


Age: 40
Joined: 25 Jan 2011
Posts: 331




Post: #3   PostPosted: Mon Nov 06, 2017 8:22 pm    Post subject: Reply with quote

I checked it at idle since the cycling was clearly noticeable So I got a small R134 canister and a gauge. The refrigerant was low, now the compressor stays on and air blows cold, all seems fine.
I don't know how bad of a leak I have... will wait & watch.

thanks
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    2GN.ORG Forum Index -> General 2nd Gen Discussion All times are UTC - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B © 2001, 2005 p h p B B Group
2GN.org Decals
East Coast Neons