dtjackten progress log..... soon to come twincharged

Do you have a project going or will you be starting a project here very soon and just want to keep a log of everything you and when? Share with everyone every step of the way what sort of progress you are making on your project.
esteinmaier
Supporting Vendor
Posts: 3324
Joined: Fri Dec 09, 2005 3:40 pm

Post by esteinmaier » Mon May 09, 2011 4:28 pm

You need to be richer though. Tuning it richer lets you keep the cylinders cooler, therefore advancing timing more without detonation, therefore making more power given the same boost level.
ASP - First NGC SOHC in the 13s and the 12s. First SOHC neon over 500whp. First NGC Neon on MS.
Winston Churchill wrote:Yes, Madam, I am drunk, but in the morning I shall be sober and you will still be ugly.

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Mon May 09, 2011 5:39 pm

thanks neonpa and erick for straitening up that for me. i love this forum.. lol will keep tuning till it richens up more...

thanks again guys :thumbup:
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

quicksilvr
Former Moderator
Posts: 3228
Joined: Fri Jul 30, 2004 7:19 pm
Location: St. Joseph, MO
Contact:

Post by quicksilvr » Mon May 09, 2011 6:35 pm

dtjackten wrote:thanks neonpa and erick for straitening up that for me. i love this forum.. lol will keep tuning till it richens up more...

thanks again guys :thumbup:

Yes, Josh (turbodudey) learned the hard way that not enough fuel is a bad thing. I think he was probably running 13-13.5 AFR at 18psi and pretty aggresive timing when he melted cyl #1. When I tune the car after we install the new turbo, I'm aiming for a 12- 12.5 AFR at WOT and I'm honestly not sure exactly what the timing will be...mostly because I don't know what it is right now. But it will be safe. :)

If the yellow car makes it to Carlisle, I'm definitely going to have Erick give my tune a "tune-up", lol.
-Dave
Image
2001 Dodge Neon R/T

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Mon May 09, 2011 8:00 pm

after looking at my afr tables in tuner studio they were mildly messed up, but i got a good table from erick and now i should be on my way.... i need to do more wot pulls with the car, but that will have to wait till my back stops killing me....... :(
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

esteinmaier
Supporting Vendor
Posts: 3324
Joined: Fri Dec 09, 2005 3:40 pm

Post by esteinmaier » Tue May 10, 2011 8:15 am

They actually weren't that terrible. They were better than the average RRFPR would result in. But the one I sent you will help a lot with safety. You should be able to get to 25psi pretty easily on the table I sent you on 93 octane as long as you listen for knock and adjust the timing table appropriately. Possibly more.
ASP - First NGC SOHC in the 13s and the 12s. First SOHC neon over 500whp. First NGC Neon on MS.
Winston Churchill wrote:Yes, Madam, I am drunk, but in the morning I shall be sober and you will still be ugly.

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Tue May 10, 2011 8:25 am

and that 25 lbs should put me at my goal.... :)

thanks again for all your help erick!!
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Sat May 14, 2011 3:32 pm

well my back is finally starting to feel better, so i got a call yesterday that my vinals were done... so i went to the shop to get them... alittle big i thought at first. as most of the companys had locked there logo from being copied.... oh well...

a few installed pics, now remember this is not all finished, the back wall is just sitting in its location... i like how it broke up all the black in the back seat.... due to rain for the next four days i will be prolly working on getting this finished up tomorrow.

Image

Image

Image

some props to Erick and asp for all his help.
Image


i know a little ricey maybe??? its not down the doors, or hood, something maybe alittle different...... i needed something to break up the over amount of black in the car..... this fits well i think..
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

acr
BANNED
Posts: 403
Joined: Thu Jan 21, 2010 3:49 pm

Post by acr » Sat May 14, 2011 4:12 pm

loose the stickers and speakers IMO

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Sun May 15, 2011 8:44 pm

this car is not ment to be a full drag car.. lol, just remember it is the closest thing to a show and go car i would come up with, lol, gutting the back is something i never really planned on doing, strickly because its a sedan.... but when i got a great deal on the sparcos i had to decide what to do, a stock bench COULD have went back in, but with the nitrous bottle, and speakers in it i would have had to change almost the whole interior of the car... someday if i can find another great deal on sparco speeds to match they will be going back there like the old setup.

but thank you for your opinion, my next car u will love acr, lol
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Tue May 17, 2011 7:27 pm

well, the last few days it has rained, rained, and well rained.... anyway, i have been trying to get my shiftlights to work, and well i got them to work tonight when i got home. easy to do honestly.

i need to get the flat shift wired up next, it is going to rain all week, so i have plenty of time to work on it by the looks.
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Sat May 21, 2011 8:17 pm

well i have been having a problem with my clutch slave or master cylinder now for the last couple years. i drove the car last night and today, and it has been a pita to drive, so come monday i am going to order a clutch master and slave cylinder so i will have all new stuff. then i should not have a problem. i had a problem with this same thing back when i had the centerforce clutch, now with the act, it is worse... so the car will be coming apart yet again... :roll:
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Mon May 23, 2011 6:11 pm

i am confused. well the clip broke that holds the master cylinder to the clutch, i drove it to and from work, and it shifted great. just like my stock 05, but i just dont get why it is doing this... i ziptied the rod to the side of the pedal, and drove it fine...

i am wondering if with the clip being broke (again) would the master cylinder possibly get air into the system? seeings it is pushed out to the very end of the pedal? idk, but i am going to keep driving it and see what happens i guess.....

any ideas would be very helpfull. tunning is going well, today i did a few wot pulls at 14 psi. afrs are alot better/safer, i will be jumping it just a little more, for my fifteen psi range i am looking for being daily driven. it pulls nice at 15 psi. and i can keep tires on the front of the car at wot. :lol: well, kinda. hahah
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Wed Jun 01, 2011 10:10 pm

cant win this year with the car.... with the clutch being a huge pita. and now i have another problem. i am hoping this is minor.

here it goes.

everytime i started the car for the last week the car will idle good around 1k. i am going to say with in fifteen seconds of the car idling ok the car starts to idle terrible. from 500 to around 1400 rpms. revs up and down up and down for a good ten or more seconds, then usually dies.... if not alittle longer then dies...

i tried richening my ve tables and still did the same thing. so tonight i took the ten min and changed over to stock ecu... still the same thing... idles terrible. but not AS BAD on stock ecu.. only about 600 to 1000 rpms, still not right.... i am thinking vaccum leak someware in the system... but i checked all of that. and everything looks ok... i may put a few clamps on the lines coming off the intake manifold. and see if that helps. as i noticed they were alittle sloppy when i installed the stock injectors.

prolly will not do much to it tonight but any ideas would be helpfull...... i am hoping timing or something worse is not a issue.

today is the first time i have really messed with it. and it seems like it is something simple.... other thought is iac valve?????
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

r/tguy02
2GN Member
Posts: 3644
Joined: Sat Jul 07, 2007 11:42 pm
Location: carlisle, pa.

Post by r/tguy02 » Thu Jun 02, 2011 8:46 am

dtjackten wrote:i am confused. well the clip broke that holds the master cylinder to the clutch, i drove it to and from work, and it shifted great. just like my stock 05, but i just dont get why it is doing this... i ziptied the rod to the side of the pedal, and drove it fine...

i am wondering if with the clip being broke (again) would the master cylinder possibly get air into the system? seeings it is pushed out to the very end of the pedal? idk, but i am going to keep driving it and see what happens i guess.....
Lemme get this straight, the clip that connects the master cyl to the clutch pedal is what broke yes?
if yes, that shouldnt be a reason for air to get in the line, you may however not have full pedal travel, which is what is causing your symptoms.
As for it continuously breaking you might just want to buy the billet MPX one, just be sure to install it properly or you can bend the rod.
Justin
[02 R/T sold][00 Highline sold][04 r/t scrapped][95 NYG Sport coupe][01 r/t DD]
http://www.cardomain.com/ride/2931823

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Thu Jun 02, 2011 9:51 am

i am going to get an upgraded hydrolic system from asp to fix my clutch issue. (hoping to order next week)

as for the idle issue i found out that my stock map sensor had cam loose and was not connected. i pushed it in and the stock computer ran fine. changed it back over to ms today idled great... i was glad it was something simple... :) the pigtail has been broke since i have bought the car. and i need to replace it.
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

User avatar
Forest Green 2k
2GN Member
Posts: 760
Joined: Sun Feb 14, 2010 8:56 pm
Location: Buffalo, NY

Post by Forest Green 2k » Thu Jun 02, 2011 10:19 am

Nice :)
2000 Forest Green - SOLD

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Tue Jun 07, 2011 9:28 pm

well. the plan for this week was to get the asp hydrolic clutch upgrade.... but my friend came back from the military and has had one of these bad boys sitting at his house for the last year... i asked him about it on his last leave and he said he was not sure what he was going to do with it... well i saw him last night and he said that i could buy it if i was still interested.... told me i could have it for 250.... needless to say... i go and give him the money on thursday... he is getting stationed in cali. and needs travaling money.... i think i pritty much stole it... brand new in box, never opened.


http://aboutgadgets.net/2010/10/kenwood-ddx-516-review/


granted i know the clutch upgrade is way more important. but this was something i have always wanted in the car just never wanted to spend 700+ dollars on one....



let the bashing begin i am sure. :P
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

User avatar
wiggyx
2GN Member
Posts: 686
Joined: Thu Oct 02, 2008 2:04 pm
Location: Cleveland, Ohio

Post by wiggyx » Tue Jun 07, 2011 11:02 pm

quicksilvr wrote:
dtjackten wrote:Yes, Josh (turbodudey) learned the hard way that not enough fuel is a bad thing. I think he was probably running 13-13.5 AFR at 18psi and pretty aggresive timing when he melted cyl #1. When I tune the car after we install the new turbo, I'm aiming for a 12- 12.5 AFR at WOT and I'm honestly not sure exactly what the timing will be...mostly because I don't know what it is right now. But it will be safe. :)

If the yellow car makes it to Carlisle, I'm definitely going to have Erick give my tune a "tune-up", lol.
12-12.5 is pretty damned aggressive, especially for a street tune. 13-up is borderline insane.

11.00 is pretty safe for a street tune, 11.5 is generally a good goal for a street tune.

User avatar
speed127
2011 Gold Contributor
Posts: 895
Joined: Mon Jan 11, 2010 6:40 pm
Location: Philly

Post by speed127 » Tue Jun 07, 2011 11:13 pm

SWEET DEAL!!!!!! who needs a clutch anyway
- Custom or Nuthin -
-My SRT4 swap project log-
viewtopic.php?p=923967#923967
-My 2nd gen progress log-
viewtopic.php?t=52665&highlight=
-My 1st gen project log-
http://forums.neons.org/viewtopic.php?f ... 7#p3090897

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Fri Jun 10, 2011 11:45 am

ordered the asp hydrolic upgrade this morning as well. am going to get the old stuff out while i am waiting for it to arrive and also get the new headunit in while i am waiting. :) hoping to have it blistering tires again in a couple weeks.

thanks again erick! :thumbup:
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

r/tguy02
2GN Member
Posts: 3644
Joined: Sat Jul 07, 2007 11:42 pm
Location: carlisle, pa.

Post by r/tguy02 » Fri Jun 10, 2011 12:23 pm

nice head unit, i really like kenwood's stuff!
Justin
[02 R/T sold][00 Highline sold][04 r/t scrapped][95 NYG Sport coupe][01 r/t DD]
http://www.cardomain.com/ride/2931823

heydockyle
2011 Silver Contributor
Posts: 4829
Joined: Mon Jul 14, 2008 6:09 pm
Location: Uniontown, Pennsylvania

Post by heydockyle » Fri Jun 10, 2011 1:22 pm

Anything above 12 and I get scared and add fuel lol.
Image
05 OB SRT-4 - AGP Stg 3 Delta 44 Turbo w/ Supporting mods
98 Platinum Coupe - 2.4 Swap
98 Flame Red Sedan - DD Slow
98 Sport Coupe - Totaled
05 SXT - Sold

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Sun Jun 26, 2011 8:46 am

well since the car has been down i have been fixing odd and end things on the car when i have time and feel like it. my ebrake now works. a simple adjustment. and now that makes my turbo timer functional as well. :)

also got my new kenwood headunit in. it is pritty sick, touch screen exc. a few pics

Image

i also pulled the 02 out of the garage to do some damage fixing on the 05 when i hit a racoon this past week. so decided to take a few pics of the engine. the rest of the car is sooo dirty so i did not bother.

Image

Image

and something about this one i like... not sure why.

Image

that is all for now.
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

sxxxt
2GN Member
Posts: 1667
Joined: Tue Oct 16, 2007 7:43 am

Post by sxxxt » Sun Jun 26, 2011 9:21 am

Wow that engin bay n the stuff that u did to it all ties really well with eachother Nd looks amazing...

measy27
2GN Member
Posts: 1871
Joined: Sun Jan 13, 2008 8:58 pm
Location: Chicopee,Ma

Post by measy27 » Sun Jun 26, 2011 9:07 pm

Sick engine bay. Love it!
'06 Nissan Murano S AWD

LilSparkPlug
2GN Veteran
Posts: 12206
Joined: Thu Jan 10, 2008 4:49 pm
Location: RI

Post by LilSparkPlug » Sun Jun 26, 2011 10:09 pm

I like the retros, I really wish you had a grille though :(

acr
BANNED
Posts: 403
Joined: Thu Jan 21, 2010 3:49 pm

Post by acr » Mon Jun 27, 2011 4:18 pm

+1 on the grille

User avatar
JeffM
2GN Member
Posts: 3588
Joined: Tue Nov 04, 2008 8:02 pm
Location: Vermont

Post by JeffM » Mon Jun 27, 2011 4:26 pm

Damn, that bay looks awesome. Everything just looks so tight-knit and looks like it's meant to be there. Good work :thumbup:
Image

dtjackten
2GN Member
Posts: 2948
Joined: Tue Feb 26, 2008 7:14 pm

Post by dtjackten » Mon Jun 27, 2011 10:21 pm

thanks guys and gals, the grille is still a maybe. i really need to get a hold of smallblock to see if he still has one or not. lol. it may not matter anyway after this winter, the bumper may need another "small" modification. :twisted:



i need a way to fit a godspeed intercooler behind it and still get air... :)

hoping to have a video up by this weekend if everything goes well.
304whp and 285 ft lbs.... 15psi.
*on the way to 400whp*
dave

Image

smallblockfreak
2GN Member
Posts: 542
Joined: Mon Jul 28, 2008 6:38 pm
Location: Scio, NY

Post by smallblockfreak » Mon Jun 27, 2011 11:33 pm

I haz one. Trade you front bumpers.
Image

Post Reply

Return to “Progress/Project Log”