p0141 o2 heater saga... need help

Is your car throwing codes or are you having a hard time passing your state or county emission test? Ask how to fix it here.
Post Reply
sidepipe87
2009 Silver Contributor
Posts: 9488
Joined: Fri May 30, 2008 5:35 pm
Location: Pittsburgh, PA

p0141 o2 heater saga... need help

Post by sidepipe87 » Mon Jul 01, 2013 12:47 pm

So I've had this CEL on in my yellow stage 3 car since I got it and after a few failed attempts to fix it, wrote it off... well now it's inspection time I need to get the CEL to go away so the car will pass emissions testing. I need some ideas what to try. Here's what I have and have not tried:

BTW - the car is stage 3 so from what I've read it shouldn't care about the downstream o2 sensor as long as it's plugged in and functioning.

When I got the car there was no downstream o2, it had a wideband plugged into the cat in it's place. I put a used working o2 in that I had... light came back on but the p0038 I also had went away

I bought a brand new aftermarket direct fir bosch sensor, light came back on and I stopped messing with it.

This past weekend I traced the wire back to pin 17 on the PCM C2 connector, its BR/VT. I cannot find a cut in the wire anywhere.

With the key on, car off I tested the voltage of that pin at the PCM and it was 1.4 volts... not sure if that is normal or low.

I put another good known working sensor in (zip tied out of the way) light came back on.

What I haven't tried:

-known good sensor from silver car.
-removing wideband o2 from cat and sticking the o2 back in there (from what I read this shouldn't matter)
-running a wire directly from the PCM pin to the o2 heater element pin.

I'm at a loss with this...

jrumann59
2009 Platinum Contributor
Posts: 639
Joined: Sun Jul 09, 2006 7:47 pm
Location: Edgewood, MD

Post by jrumann59 » Mon Jul 01, 2013 1:17 pm

Is the ECU stage 3? If it doesn't care about the DS O2 then it should not throw a code. If its a stock or ECU I would think that the DS is getting some weird readings since all the mods that go with the stage 3

have you thought about this http://www.ubertechnics.com/o2_simulator_2.5.aspx
bone-yard-racing wrote:
Remind him of two things for the mustang:
Slow in=Fast out
Fast in=Ambulance out
ImageImage

sidepipe87
2009 Silver Contributor
Posts: 9488
Joined: Fri May 30, 2008 5:35 pm
Location: Pittsburgh, PA

Post by sidepipe87 » Mon Jul 01, 2013 2:26 pm

It is a dealer installed stage 3 pcm, yes. It has stage 3 with toys and it has the box wired in that is supposed to unset the flag which s3 throws so you wont pass emissions. I've never heard of the thing you posted and i'd assume there must be a logical solution somewhere else in my mess before i start throwing money at it
PM me for your 03+ PCM SKIM/VIN flashing needs.

jrumann59
2009 Platinum Contributor
Posts: 639
Joined: Sun Jul 09, 2006 7:47 pm
Location: Edgewood, MD

Post by jrumann59 » Mon Jul 01, 2013 3:26 pm

sidepipe87 wrote:It is a dealer installed stage 3 pcm, yes. It has stage 3 with toys and it has the box wired in that is supposed to unset the flag which s3 throws so you wont pass emissions. I've never heard of the thing you posted and i'd assume there must be a logical solution somewhere else in my mess before i start throwing money at it
Could it be the wiring to the module that is supposed to bypass the DS O2?
bone-yard-racing wrote:
Remind him of two things for the mustang:
Slow in=Fast out
Fast in=Ambulance out
ImageImage

sidepipe87
2009 Silver Contributor
Posts: 9488
Joined: Fri May 30, 2008 5:35 pm
Location: Pittsburgh, PA

Post by sidepipe87 » Mon Jul 01, 2013 5:49 pm

I thought of that, but as far as I know the bypass box just clears a code that doesn't actually trip the CEL to come on. it sets some obscure code for at ATX trans or something. it might be worth a shot though at this point.
PM me for your 03+ PCM SKIM/VIN flashing needs.

Post Reply

Return to “Emissions”