fog lights will not turn on

Got a question on outside appearance modifications. Questions about body kits, exterior lighting, just anything thats a visual mod on the "exterior" of the car. Ask those questions here.
Post Reply
Brandon
n00b
Posts: 10
Joined: Sun Apr 27, 2014 12:13 am
Location: Florence, Colorado

fog lights will not turn on

Post by Brandon » Sun Apr 27, 2014 2:02 pm

i am new to this forum but so far i am really enjoying myself, anyway onto the question. i have an 03 dodge neon sxt and i just put new bulbs in the factory fog lights. i cannot get them to come on, any idea what could be going on here?

my first thought was it could be a fuse so i checked the fuse and it was fine. then i seen a wiring diagram for the fog lights made by someone here on this site and seen that the number 15 fuse was somehow intermingled into the fog light system so i checked that as well and that fuse was fine too. any ideas or trouble shooting steps would be much appreciated.
[/img][url]

Midnight_Rider
2014 Platinum Contributor
Posts: 7692
Joined: Wed Aug 02, 2006 2:49 am
Location: Indianapolis, IN

Post by Midnight_Rider » Sun Apr 27, 2014 2:32 pm

Welcome to 2GN! :hello2:

I'm sure that you'll answer "yes" to this question but was your multifunction switch ("MFS") working before you installed the new bulbs?
viewtopic.php?t=20318
Last edited by Midnight_Rider on Sun Apr 27, 2014 2:35 pm, edited 1 time in total.
Official "I'm Going To Drive My Neon 'til It Dies" Club #10

Brandon
n00b
Posts: 10
Joined: Sun Apr 27, 2014 12:13 am
Location: Florence, Colorado

Post by Brandon » Sun Apr 27, 2014 2:33 pm

yes
[/img][url]

Midnight_Rider
2014 Platinum Contributor
Posts: 7692
Joined: Wed Aug 02, 2006 2:49 am
Location: Indianapolis, IN

Post by Midnight_Rider » Sun Apr 27, 2014 2:37 pm

Well, you've already exceeded my knowledge on the subject LOL so I'll step aside and let one of our many experts help you.
Official "I'm Going To Drive My Neon 'til It Dies" Club #10

Brandon
n00b
Posts: 10
Joined: Sun Apr 27, 2014 12:13 am
Location: Florence, Colorado

Post by Brandon » Sun Apr 27, 2014 2:47 pm

haha well thank you for your time :D
[/img][url]

05MoparSRT4
2GN Member
Posts: 110
Joined: Tue Dec 10, 2013 6:21 pm

Post by 05MoparSRT4 » Sun Apr 27, 2014 10:07 pm

Check grounds/power if the fuse is fine. I assume your headlights turn on right?
Image

Brandon
n00b
Posts: 10
Joined: Sun Apr 27, 2014 12:13 am
Location: Florence, Colorado

Post by Brandon » Sun Apr 27, 2014 10:19 pm

I followed all the wires and one of the power wires was cut
[/img][url]

ChetNubbler
n00b
Posts: 18
Joined: Fri Jul 25, 2014 7:48 pm
Location: Vermont, United States

Post by ChetNubbler » Sun Sep 07, 2014 9:42 am

I just went through this about two months ago. mine didnt work either when i got my neon. i had to replace my MFS

http://www.amazon.com/gp/product/B000EQ ... UTF8&psc=1

everything else on the MFS worked fin except the fogs. it was a 15 minute swap, its 2 phillips screws and two torx screws. easy. does the fog icon light up on the dash when you pull out the knob? is the fuse good? are the bulbs good?

Michael7
n00b
Posts: 16
Joined: Sat Sep 06, 2014 10:37 am
Location: UK

Post by Michael7 » Sun Sep 07, 2014 2:25 pm

I believe there is a design problem with neon's MFS. It looks like it is a common problem.
I described here http://forums.neons.org/viewtopic.php?f ... 083e51a116 how I solved mine for $0.

Post Reply

Return to “Exterior”