2003 Neon Cranks but won't start, P0344 code

Have a question that your not sure what category it fits into or isn't really a specific question about a specific part? Ask it here...
Post Reply
lisad
n00b
Posts: 10
Joined: Wed Jan 03, 2018 10:21 am

2003 Neon Cranks but won't start, P0344 code

Post by lisad » Fri May 25, 2018 9:12 am

Son was driving to work and pulled into the parking lot and he says just as he did, the Check Engine light came on. He turned off the car and went to work and when he came out the car cranks but won't start. He was very low on gas (he frequently drives on fumes I think) and assumed he needed fuel so we put in 3 gallons but it still won't start. The code is P0344 -- which we have seen before but the Cam Sensor was replaced. Could intermittent electrical issues withe the Cam Sensor cause the vehicle to not start? Or is it fuel related? I would love to get the car out of the parking lot!

User avatar
jonnymopar
Junior Admin
Posts: 3013
Joined: Sat Nov 19, 2005 7:49 pm
Location: Southeastern MA

Re: 2003 Neon Cranks but won't start, P0344 code

Post by jonnymopar » Fri May 25, 2018 4:00 pm

If the computer isn't seeing a signal from the cam sensor, it definitely will not run. Check all around the cam sensor and check the connections. You might even want to try having someone slowly move the wires around while the car is cranking to see if it's a loose/bad connection. If the computer all of a sudden sees a signal, it should start right up.
Image
Jon J.

2003 Neon SXT - 200k+ miles, still love it
1989 Daytona ES - 2.4L/A555 swapped

Official "I'm Going to Drive my Neon till it Dies" Club #148

lisad
n00b
Posts: 10
Joined: Wed Jan 03, 2018 10:21 am

Re: 2003 Neon Cranks but won't start, P0344 code

Post by lisad » Fri May 25, 2018 7:42 pm

Thank you. I appreciate your answer. For some reason I thought the car wouldn't start if the CRANKshaft sensor or signal was bad, not the CAM sensor. We'll take a look at it.

occasional demons
Junior Admin
Posts: 19110
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 Neon Cranks but won't start, P0344 code

Post by occasional demons » Sat May 26, 2018 12:13 am

All neons, except for 1996 model year, should start (In limp mode) with the cam sensor unplugged. If the issue is the sensor and/or target magnet, it should start. If the issue is in the wiring, it may not.

It will fire the injectors in batch mode, but it should run well enough to get it home.

Assuming the timing belt is intact.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

lisad
n00b
Posts: 10
Joined: Wed Jan 03, 2018 10:21 am

Re: 2003 Neon Cranks but won't start, P0344 code

Post by lisad » Sat May 26, 2018 1:05 am

Timing belt was changed a few months ago and it is intact. It is rotating when I crank so I guess that means it's OK. I tried spraying starter fluid into the manifold but I'm not sure that I sprayed it in the right place as it didn't even try to start. I took off the air filter cover and the air filter and sprayed into there -- was that correct?

The fuel pump is priming as as I hear a noise and then a click so I believe it is priming so assume it's OK. I don't have a pressure gauge for the fuel so is there a way to confirm that there is fuel pressure? Could the pump be good but it wouldn't have pressure? I disconnected the neg battery cable and no codes are coming up for now. I am going to check to see if I have spark and I assume if I have spark then the crank or cam sensors are good?

I literally have changed about every sensor in this car except for the crank sensor. I changed the cam sensor and magnet a few months ago. I read that sometimes the crank sensor or wiring could be bad but it shows up in the cam sensor. I hated doing the cam sensor it was very frustrating. And I need to find out where the crank sensor is!

occasional demons
Junior Admin
Posts: 19110
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 Neon Cranks but won't start, P0344 code

Post by occasional demons » Mon May 28, 2018 9:59 pm

Ether is risky, but where you sprayed it would have worked if there was spark.

The easiest way to check for spark is to put an old spark plug into the wire and lay it on something grounded. You can wrap a wire around the threads and run it to the battery negative.

A bad crank sensor could possibly affect the cam sensor circuit. On a 2003 to 2005, it is near the starter.

If it isn't firing with the cam sensor unplugged, that might be my next step if the cam timing is good.

Since it didn't do anything with the ether, it sort of rules out a fuel issue. If it doesn't have spark from either coil, the fuel injectors probably aren't firing either. A bad crank sensor will not give the PCM a crank signal of 200 rpm or more, so the ASD relay may not be engaging, therefore no power to the coil center wire, or the common for the fuel injectors. (Dark Green/Orange wire)
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

lisad
n00b
Posts: 10
Joined: Wed Jan 03, 2018 10:21 am

Re: 2003 Neon Cranks but won't start, P0344 code

Post by lisad » Wed May 30, 2018 10:18 am

Thanks all. Update -- We got it towed home and I called a company called Your Mechanic, who hooked it up to a fancy scanner and he told me it was the MAP sensor that was bad. He tested his theory by unplugging the IAC sensor and it actually started, albeit briefly, then died. That made no sense to me, but whatever. He said -- put in a new MAP sensor and it will work, and he left. I put in a new one (aftermarket) and guess what? Car still does not start! They are coming back today to rescan. Literally the MAP and Crank sensors are the only two that I haven't replaced since we purchased the car so it made sense to me that the MAP was failing or failed.

However, we are still in the same boat. I can only assume that he knows there is spark based on the scanner but I have no idea. He'll be here soon (a different mechanic) so we'll see. I'll keep you posted.

occasional demons
Junior Admin
Posts: 19110
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 Neon Cranks but won't start, P0344 code

Post by occasional demons » Wed May 30, 2018 1:57 pm

LOL, I don't see the connection between the MAP and the IAC. First I've heard of that one.

With the IAC unplugged, it would be very hard for the engine to start and run, unless the throttle is cracked open a bit. In normal operation, the IAC solenoid opens all the way when keyed on. As soon as it fires, it adjusts down to achieve the proper idle. It needs to be open enough to let air in.

If there was a MAP issue, you should have had a CEL/code for it.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

Post Reply

Return to “General 2nd Gen Discussion”