Need help with 04 sxt

Have a question that your not sure what category it fits into or isn't really a specific question about a specific part? Ask it here...
Post Reply
mjbzak
n00b
Posts: 4
Joined: Wed Sep 24, 2014 8:03 am

Need help with 04 sxt

Post by mjbzak » Wed Sep 24, 2014 8:14 am

Ok so I need help with my girlfriends 04 neon sxt. The problem we are having with it is a hot start problem. The problem we are having is once when have taken a trip with it long enough to get it up to operating temp and we shut it off to go into a store when we come back it wont start. I will give you a background on what I have fixed or replaced already hoping to fix the problem and something that seems to sometimes make a difference in starting it but not all the time. So far in the past year I have replaced the coil pack and the cam position sensor. And the thing that we do sometimes that helps is if we get nothing when we turn the key we will move the shifter into neutral and sometimes that will make a difference but not always. Any help you all could give me would be greatly appreciated.

User avatar
sidepipe87
2009 Silver Contributor
Posts: 9491
Joined: Fri May 30, 2008 5:35 pm
Location: Pittsburgh, PA
Contact:

Post by sidepipe87 » Wed Sep 24, 2014 8:49 am

When you say it won't start.... does it crank for a long time? does the starter just click? does it do nothing?
PM me for your 03+ PCM SKIM/VIN flashing needs. Neon PCMs Plus

mjbzak
n00b
Posts: 4
Joined: Wed Sep 24, 2014 8:03 am

Post by mjbzak » Wed Sep 24, 2014 8:54 am

what it will do is sometime it will try to start but then stops or you turn the key and get nothing and if you keep trying sometimes it try's to but cranks for a second or 2 then stops and like in the original post sometimes if you put it in neutral it will start or it might just crank for a second or 2

occasional demons
Junior Admin
Posts: 19315
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Wed Sep 24, 2014 9:34 am

So it is pretty much just the starter/circuit. Once the starter does work properly it will fire up and run.

Probably an issue with the starter. You can try swapping the starter and horn relay to eliminate that part of the circuit.

If you have a test light, you could check to see if the relay is putting power to the starter solenoid, or if the relay is getting power each time the key is turned. Or have a helper turn the key to see if the relay is clicking.

Check the ground near the driver side headlamp also.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

mjbzak
n00b
Posts: 4
Joined: Wed Sep 24, 2014 8:03 am

Post by mjbzak » Wed Sep 24, 2014 9:38 am

in the past I've switched the relays around and they seemed to help but not every time so would you still think that is the problem? or should I try removing the starter and having it tested?

occasional demons
Junior Admin
Posts: 19315
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Wed Sep 24, 2014 9:46 am

Then it is more the starter, unless the relay is not getting a consistent signal from either the PCM (ground side) or the ign switch (hot side).

If it clicks every time the key is turned when it won't crank, then it is probably the starter.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

mjbzak
n00b
Posts: 4
Joined: Wed Sep 24, 2014 8:03 am

Post by mjbzak » Wed Sep 24, 2014 9:56 am

when the problem occurs when you turn the key sometimes you get nothing no clicking or anything but if you keep trying sometimes it will try and turn over but stops after a second or 2 and sometimes if you get nothing if you put it in neutral sometimes you will get something. it only happens when its hot and been run for awhile. if you let the car cool down it goes back to starting without a problem until it gets hot again. sorry not trying to repeat the same thing over and over again just trying to give you the most info I can so you can have the best idea and give me the best advice. thanks for all the help already

User avatar
sidepipe87
2009 Silver Contributor
Posts: 9491
Joined: Fri May 30, 2008 5:35 pm
Location: Pittsburgh, PA
Contact:

Post by sidepipe87 » Wed Sep 24, 2014 12:12 pm

If it doesn't start, try tapping on the starter a few times with something like the handle of a long screwdriver or a prybar. There may be a bad spot on the contacts of the starter causing it to not start.
PM me for your 03+ PCM SKIM/VIN flashing needs. Neon PCMs Plus

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Wed Sep 24, 2014 12:13 pm

Or maybe the ignition cylinder is faulty? How many miles?

Is that thing hot or warm when you pull the key?
a neon - what else ?

occasional demons
Junior Admin
Posts: 19315
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Wed Sep 24, 2014 12:34 pm

occasional demons wrote:Then it is more the starter, unless the relay is not getting a consistent signal from either the PCM (ground side) or the ign switch (hot side).

If it clicks every time the key is turned when it won't crank, then it is probably the starter.
Sorry, I should have specified the relay clicking, not the starter. You will almost have to tell by putting your finger on it, as they don't click that loud, and if there is background noise....


Just trying to go through everything before condemning the starter. Like Sidepipe87 said, you could try giving it a firm tap with something to see if that helps.

The contact in the solenoid might be getting burnt also. It is just as cheap to replace the starter, even if you could get a solenoid for it. The last time I priced a solenoid, it was $90. A reman starter for that vehicle was $120.

Basically, the ignition switch and the PCM control the relay coil, which pulls in the relay contacts.

The relay contacts energize the solenoid coil, which moves the Bendix into the bellhousing to engage the starter drive gear to the ring gear. It also makes the contact for the starter motor.

If that contact is getting burnt it will give you random results. The armature and brushes can also be shot.

If the PNS switch is bad, then the PCM won't ground the relay coil. There are other inputs that will cause it to not ground it, but I don't think any of that is the issue here, since it is fine on a cold start.

Being the starter is getting the hottest out of all the components, and the relay the second hottest.... But, we just can't rule everything else out based on that.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

MichNeon
2GN Member
Posts: 156
Joined: Sun Sep 15, 2013 12:34 pm
Location: Metro Detroit, Michigan

Post by MichNeon » Sat Oct 11, 2014 9:13 pm

From what i'm reading here, it sounds like a temp related issue with the starter. Obviously, when it is cold, there are no problems. When it is hot, it does'nt crank. Check and verify that the starter has power to it, and that the solenoid on the starter is getting the signal from the relay, when it is hot. If the signal and the power are good, check the ground cable that is bolted to the bellhousing near the starter, it needs to be clean and tight. If that is good, then you need a starter.
2004 R/T, DD
1995 Sport Sedan (The Frog), Given to my brother.
30 year Chrysler Tech.

Post Reply

Return to “General 2nd Gen Discussion”