Low idle speed

This is the place to ask questions about your engine components like cams, valves, pistons… just anything that is generally "engine" specific. This also includes questions about exhaust systems such as exhaust manifolds, piping size, mufflers, ect...
Post Reply
User avatar
SzaKrisz86
n00b
Posts: 3
Joined: Mon Oct 29, 2018 6:08 pm

Low idle speed

Post by SzaKrisz86 » Tue Oct 30, 2018 7:54 am

Hi all, please help!

At first thank you for being a member on the forum. I have a 2002 Chrysler Neon gen 2. - 2.0L SOHC, 41TE – 116k km and same problem:

When the engine warms up and I stop at the red light, sometimes the idle speed drops to ~ 500-600 rpm, but not always. And when the idle is such low, the engine oil pressure indicator light will sometimes light up, but when it returns to normal idle (~ 850-900 rpm), the oil pressure warning light goes off immediately.

In the usual way, the idle speed will increase if:
1) power steering operates,
2) A/C switches on,
3) I switch the ATX to N.

Should I worry about the engine oil pressure, or if the engine oil pump is not working in the optimum range at too low idle speed?

I've read a lot about the low idle speed problem, but I found many different answers:
- „1/8" hole trick” on throttle body plate,
- throttle body clean,
- sensors check and clean,
- engine oil pressure switch replace,
- TCM / PCM Flash...

… Has anyone had a similar experience? Which solution helped you?

occasional demons
Junior Admin
Posts: 19162
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: Low idle speed

Post by occasional demons » Tue Oct 30, 2018 11:38 am

I have had my 2.0 idle as low as 400 rpm, without the oil light coming on.

The cheapest thing, other than putting a small hole in the throttle plate to try, would be to replace the oil pressure switch, as they are known to have issues.

If it is the oil pressure switch going bad, the hole in the throttle plate will only be a temporary fix to the oil light.

IIRC, the switch will make contact at ~4 psi.


And Welcome to the forum!
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
SzaKrisz86
n00b
Posts: 3
Joined: Mon Oct 29, 2018 6:08 pm

Re: Low idle speed

Post by SzaKrisz86 » Wed Oct 31, 2018 4:06 am

Thanks for the answer, at first I'll replace the oil pressure sensor, but I can't find a solution for the low idle speed.
Yesterday, I cleaned the throttle body, but the problem wasn't solved. (The throttle body plate seemed to be made of steel, not plastic, so it wouldn't be easy to drill.)
(I noticed that the engine oil pressure sensor light only lit when the idle speed drops to ~ 500 rpm. As soon as I move the steering wheel, I turn on the A/C, or I move the gear to N, the light goes off always.)

occasional demons
Junior Admin
Posts: 19162
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: Low idle speed

Post by occasional demons » Wed Oct 31, 2018 8:12 am

If the throttle body is black plastic, the throttle plate should also be plastic, unless someone installed a 1st gen throttle plate into it.

If the throttle body is aluminum, then it is either an aftermarket, or another make/model/year someone installed on your car.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

Post Reply

Return to “Engine”