Questions about boost, no issues currently.

Have a question related to Turbos, Nitrous, Supercharging, ect... ask it here.
User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Questions about boost, no issues currently.

Post by catalyst » Fri Nov 30, 2007 7:12 pm

What is the stock boost spike (the highest psi) that a stock '05 will hit, cause I'm only getting 5psi

SHould I go through and tighten up all the connections and bolts?

sorry I'm a :tardbang:
Last edited by catalyst on Sun Aug 26, 2018 12:32 pm, edited 5 times in total.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
INVUJerry
2GN Veteran
Posts: 6499
Joined: Mon Nov 21, 2005 9:55 pm
Location: Hanover, PA
Contact:

Post by INVUJerry » Fri Nov 30, 2007 7:16 pm

In your SXT without a turbo kit? You shouldn't hit any PSI.
Image
So many neons so little time.

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Fri Nov 30, 2007 7:18 pm

oh yeah sory forgot to update my profile
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
INVUJerry
2GN Veteran
Posts: 6499
Joined: Mon Nov 21, 2005 9:55 pm
Location: Hanover, PA
Contact:

Post by INVUJerry » Fri Nov 30, 2007 7:26 pm

Oh damn. Hmm. You can buy a boost leak kit, makes smoke come from where the leaks are. You could also check the common places, at the throttle body, where it connects to the intercooler (both sides), and where the boost pipe connects to the turbo. Remember SRTforums can help too!
Image
So many neons so little time.

User avatar
dysphagia
2GN Member
Posts: 164
Joined: Sun Jun 10, 2007 2:58 pm

Post by dysphagia » Fri Nov 30, 2007 7:27 pm

you should see about 14 stock, 5 psi could be a boost leak or your vac lines were fuggered with before you bought it.

do a boost leak test and make sure the vac lines are going to and from the wastegate and soleniod
This site used to be good....

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Fri Nov 30, 2007 7:36 pm

I found a how to for boost leak check, and I'll check vac lines and around the solenoid. If I have momre questions I'll ask them here
I'm sure I'll have more

thanks
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Fri Nov 30, 2007 7:54 pm

I just went through quickly with no tools and found a connection was completely off the hose that runs from air box to the turbo, I reconnected it and I'm gonna go buy some zip ties and other fun things.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Fri Nov 30, 2007 8:43 pm

Ok, boost is still not proper. Just talked to guy at dodge I still have warranty, but they would have to do a $90 diagnostic to see if it is covered buy waranty :cussing: and that if the boost leak was caused by a loose connection and not from any part malfunction, it would not be covered. Tomorrow I'll have to get in there and look around at all the connections. I was wondering does any one have a link to a diagram of what I'll be looking at/for?
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

Wenuden
2GN Member
Posts: 2554
Joined: Fri Apr 06, 2007 11:53 pm
Location: Alexandria, Va

Post by Wenuden » Fri Nov 30, 2007 9:18 pm

there is no boost from the air box to the turbo. that clamp should never come off, since it's not pressurized. take the intake back off, and look at the turbo inlet fins, check for cracks, chips, gunk and shaft play (put your finger on the little shaft in the middle and try to gently move it side to side. there shouldn't be much, if any, play. this should have been done before purchase) since you were probably pulling unfiltered air. the car probably had an aftermarket intake (among other things, since mods are like lays, you can never have just one) before the owner took it back to stock to sell.

go to www.srtforums.com and check the how-to section for a home made boost leak check tool. should be able to make one for less than $20 from parts found at your local home depot (go tony stewart!), lowes (fuck a jimmy johnson, hope he gets hit in the head with a 2x4 from home depot [quoted from my bro-in-law from the daytona 500 in '06 lol]), or almost any hardware store. that being said, on to the list:


the connections you need to check are:

turbo outlet to intercooler hot-side pipe (hard to get to, i believe)

hot-side pipe to intercooler (under the car, left side of the intercooler when looking at the car from the front)

intercooler to cold side pipe (right side of intercooler when looking at the car from the front, easy to get to with stock air-box out of car, also accessable from underneath)

cold side pipe to throttle body (also easy to access with stock air-box out of the car)

those 4 spots are going to have 2 crappy worm-gear clamps to check for each connection. i'd suggest replacing them with t-bolt clamps, they don't loosen up as easily. also check all of the rubber hoses (hot side coupler and cold side "pipe", turbo outlet coupler) for rips, tears and holes. i'd be willing to bet one of those has either a huge rip or the band clamp is not even snug, since 10psi is a freakin huge boost leak from a vac line.

there are also various vacuum lines that need to be checked. the vac solinoid is on top of the stock air box and has 6 or more plastic lines coming off of it. zip tie all of those lines. trace them to where they go and zip tie there too.

you should also take a look at the waste gate actuater (mounted to the turbo housing with a metal actuater arm going under a heat shield to the exhaust manifold) to be sure it's not a stage 2 (adjustable for boost control) or an aftermarket (also adjustable), and if it is, make sure it's not adjusted too tight, keeping the waste gate open and dumping boost (i think that's right, tight, might be loose that limits boost. either way, if the car was sold to you as "stock", it should not be adjustable).

i'm sure there are some vac lines i'm forgetting, someone else will chime in, i'm sure, if i did. definitely don't take it to the dealer until you've checked all of these areas, as they won't be covered by warranty unless one of the rubber hoses/couplers is torn in a manner that makes it obvious it was from boost blowing it out, and not just being cut by a tool or something.



now, with all of this having been said (and hopefully done by you soon), put a catch can on that bitch! lol.

Congrats on the pocket rocket, enjoy, dude. oh yeah, can ya edit yer sig with what color you got, and lets see some pics!!!!!

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Fri Nov 30, 2007 9:39 pm

Thanks alot for that :rockon:

I'll look at everything tomorrow. Should I be driving it with a 10psi leak? I keep it in the vacuum area of the gauge.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

Wenuden
2GN Member
Posts: 2554
Joined: Fri Apr 06, 2007 11:53 pm
Location: Alexandria, Va

Post by Wenuden » Fri Nov 30, 2007 10:32 pm

to be honest, i don't know if you should or not. i personally would not drive mine in that condition because i don't know if the motor would pull fuel during WOT based on the map reading, or if it just dumps fuel that won't have enough air to mix with into the motor. i would assume it would pull the fuel, but not being certian, i'd be parking mine till i figured it out.

i'm willing to bet you'll be back on here tomorrow saying you found a pipe going to or coming off of the intercooler that was torn or the band clamp wasn't tight at all. those 2 areas are notorious for failing on these cars. i've had my hot side coupler come off of the intercooler completely during a WOT run, and that was after having tightened all connections maybe 4 days prior.

if all of the connections are the stock worm gear clamps, i'd suggest changing to t-bolt clamps, or at least checking the stockers once a week if you get into higher boost alot or every two weeks if you drive normal with a few WOT runs every once in a while. they really suck ass. i've never had to not tighten at least a couple when i check them every other weekend.


Edit: Catch can and a check valve are great "mods", even if you want to keep the car stock for a while. take off the PCV valve and blow thru it both ways.... you'll see why. i don't think blowing 12-14 PSI into your valve cover is a good thing.

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11518
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Post by MyNeonSaysHi » Sat Dec 01, 2007 12:32 pm

Very nicely said Wenuden.

I personally rarely check my clamps. I checked em last week and they were all nice and tight.

T-bolts are a great thing to have. But I don't think it would be a good idea to put them on the intercooler side because its an oval. And worm clamps like circles not ovals so I been told on SRTforums. But they probably would be fine. Just get your worm clamps nice and tight you should be fine. Look for any holes/tears in your plumbing too. Make sure the hoses are completely all the way on. Example's:

Intercoolers sides, hotside pipe, bottom of turbo, throttle body.

Stock PSI according to Dodge stock is 11-14 PSI. I spike 14-13 and it bleeds down to 11-12. Because I know I have a leak coming from my AGP BOV.

It doesn't hurt a car to drive it with a boost leak I do believe. As long as you stay in vac. and don't go into boost.

Like Wenuden said. a catch can and a checkvalve would be a great thing to get. Keeps the boost going one way. Also keeps oil out of the damn intake manifold and your cold side part of the intercooler.



The stock throttle bodies are known to leak. If you think about it, when you do a boost leak test you are shoving air through the system when the car is off... So the throttle body stays shut. So the air just hits the damn throttle body plate and shoves it out wherever it can go. (Sticky on the ModernPerformance vendor thread on SRTforums about boost leak testing, check it out on)

Good luck with everything and ask away.

08 Acura TL-S
05 Neon SRT-4

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Sat Dec 01, 2007 12:40 pm

I'll be starting to work on her in a bit, so I'm sure the questions will fly :)
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Sat Dec 01, 2007 5:17 pm

Ok so underneath everything is fine except the cold side pipe(from IC to TB) has a bunch of oil on the bottom around the clamp.
Image

Here are the shots I could get of the vac lines and the turbo area

Image

Image

Image

Image

Image
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Sat Dec 01, 2007 7:49 pm

after tightening she seems to be better, holds 11 and spikes 15 psi.

Hope that was it.






:ban:
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

Wenuden
2GN Member
Posts: 2554
Joined: Fri Apr 06, 2007 11:53 pm
Location: Alexandria, Va

Post by Wenuden » Sat Dec 01, 2007 8:36 pm

catalyst wrote:after tightening she seems to be better, holds 11 and spikes 15 psi.

Hope that was it.






:ban:

You're in good shape now. What connections were loose?

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Sat Dec 01, 2007 8:39 pm

the one right after the air box, the one right bofore the turbo, right after the turbo, hot side before the IC, cold side right after the IC and the one right before the TB, all of 'em? I also zip tied all the vac lines. :cussing:


Man is it fun to drive now though. :rockon:
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11518
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Post by MyNeonSaysHi » Sat Dec 01, 2007 10:16 pm

Glad you got it man. Your turbo/heatshield/WGA look clean as hell too. I wish I could beadblast my turbo. :lol:

All that oil down there is normal. To get rid of it, get a catch can. Very simple easy install.

Image

See that electrical connector? I had that thing pop off before under WOT, watch out for that. :lol:





Image

No riceplate. Good. Don't buy one either.

08 Acura TL-S
05 Neon SRT-4

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Mon Dec 10, 2007 8:50 pm

Ok so now sometimes at idle, at a stop light or something, the vacum will be all over the place between 22 and 10, and the engine will chug a bit. Also on the way to the store tonight 1st gear through 3rd, I was speeding up(stop to 40mph) and the power getting to the wheels was lacking for about 2k rpm after the shift and then the whole car would buck and it would have power like normal. It did that for each shift until 3rd to 4th, all the while the boost gauge needle was jumping around in the vacum range. (should I ask about this in tranny?) On the way back from the store it was normal. Spark Plugs fouled? :confused1:
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

Wenuden
2GN Member
Posts: 2554
Joined: Fri Apr 06, 2007 11:53 pm
Location: Alexandria, Va

Post by Wenuden » Mon Dec 10, 2007 10:52 pm

Recheck your vac lines (not just the connections, the lines too) and pull the plugs. Did you check the plugs and wires when you bought it?

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Mon Dec 10, 2007 11:12 pm

nope only has 26,000 on it. My sxt's lasted untill 100k so I didn't think to check those.

The vac lines had no tears when I ziped them. What else should I check on them?
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
dysphagia
2GN Member
Posts: 164
Joined: Sun Jun 10, 2007 2:58 pm

Post by dysphagia » Tue Dec 11, 2007 2:23 am

my bet is for the vac system up towards the master cylinder, did you do a real boost leak test? and t-bolts on every joint will help even the oval ones, just squish them down a bit to oval them out, the people that claim otherwise are creating some sort of user error.
This site used to be good....

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Tue Dec 11, 2007 2:23 pm

I din't do a real leak check, just visual and tightened everything and ziped the vac lines. What are t-bolts? :banghead:

Gonna check plugs tonight and maybe get some t-bolts.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
MoxHair
2GN Member
Posts: 3801
Joined: Mon Feb 27, 2006 5:41 pm
Location: Atwater, CA; Orlando, FL
Contact:

Post by MoxHair » Tue Dec 11, 2007 6:00 pm

Spark Plugs will probably last you 6-10 thousand miles.

I change mine every 6,000.
2017 Subaru WRX STI
Road Racing > Autocross > Spirited Driving > Sitting in Traffic > Mowing Lawns > Drag Racing

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Tue Dec 11, 2007 6:10 pm

Realy, ok I geuss I'll change them, should I change the wires as well?

Is this a common thing with an SRT4?
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Tue Dec 11, 2007 8:15 pm

just replaced the spark plugs, nothing apparantly wrong with them, aside from gap.

Going on a drive now.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Tue Dec 11, 2007 8:55 pm

wasn't that simple :owned:

too dark out now, gonna check all the vacum lines tomorow.

I geuss on the good side, I wont have to replace the spark plugs for awhile.
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

User avatar
MoxHair
2GN Member
Posts: 3801
Joined: Mon Feb 27, 2006 5:41 pm
Location: Atwater, CA; Orlando, FL
Contact:

Post by MoxHair » Tue Dec 11, 2007 8:57 pm

I change my Plugs every 6,000miles and my wires every 12,000 miles

You'll be able to tell when it's time to change them when you get a miss or stutter near the top of the rev band.

I use NGK 4306s gapped at .032
2017 Subaru WRX STI
Road Racing > Autocross > Spirited Driving > Sitting in Traffic > Mowing Lawns > Drag Racing

User avatar
dysphagia
2GN Member
Posts: 164
Joined: Sun Jun 10, 2007 2:58 pm

Post by dysphagia » Tue Dec 11, 2007 11:26 pm

you're not going to be able to tell if there are any real leaks unless you put the system under pressure...just do a real boost leak test.
This site used to be good....

User avatar
catalyst
2GN Member
Posts: 447
Joined: Fri May 25, 2007 9:03 pm
Location: GA

Post by catalyst » Tue Dec 11, 2007 11:38 pm

yeah I geuss I'll have to. should have the first time :beatstick:
Image
2005 Red SRT4
Stage 2, Maddog 72-4
Still needs a paint job
Official "I'm Going to Drive My Neon till it Dies" Club #87

Post Reply

Return to “Forced Induction”