High pitched whistle on acceleration and tranny braking.

Have a question related to Turbos, Nitrous, Supercharging, ect... ask it here.
Post Reply
User avatar
iThane
2GN Member
Posts: 1251
Joined: Thu Sep 30, 2010 5:33 pm
Location: Las Vegas, NV

High pitched whistle on acceleration and tranny braking.

Post by iThane » Tue Oct 08, 2013 12:01 am

As the title suggests, I've got this really annoying whistle which can be heard in the video posted:

Image

Apologies for the music :lol:

It all started when I first installed my BOV. It started off as a constant whistle at idle, but eventually wore down to where now I only hear it once the engine has warmed up and I WOT or transmission brake. My buddies and I heard it coming from the back of the engine near the turbo, so I assumed it was the block off plate. Since then, I've tried 3 different gasket materials and several different sealants. Unfortunately, none resolved the whistle. Another friend of mine was taking a look at my engine bay when he claimed it sounded like it was coming from the BOV. He found that my vacuum line coming from the charge pipe had been chewed through by a damn animal, so I fixed the leak, but still hear the whistle. I'm really just curious if anyone has had a similar issue.. I assumed it was related to the induction system since it all started after the bov install, but what would cause it to whistle when I begin to tranny brake? Maybe the vacuum making the same whistle as the boost pressurizing the leak?

Halp pl0x.
Image
My Progress Log
Official "I'm Going to Drive My Neon till it Dies" Club #000104

ragek23
2GN Member
Posts: 2476
Joined: Wed Sep 27, 2006 9:22 am
Location: Torrington, CT

Post by ragek23 » Sun Dec 01, 2013 12:40 pm

U know I have a similar sound coming from my NA car but only around 3K rpm. Its odd it started a week ago. I have no idea what is.

2002 Neon SXT Sold
2006 EVO MR Weekend Warrior
2003 SRT 4 DD
-Kevin

Image

User avatar
akirony
2GN Member
Posts: 437
Joined: Wed Sep 15, 2010 9:07 pm
Location: dallas

Post by akirony » Mon Feb 03, 2014 6:58 pm

Hmm Ive always had that. I always thought it was just the intake vacuum causing air to hit the TB at a certain rpm. Its never affected anything though. People trip out thinking my car is boosted because of it lol.
Have car-have car problems. Have srt4-have speed problems
Image

Post Reply

Return to “Forced Induction”