Page 1 of 1

power steering pump ?

Posted: Tue May 12, 2009 10:45 am
by danielc24
i took all the bolts out behind the pulley and took out the bolt on the other side under the radiator hose and all i can do is push it down. I need to remove it and put a new one on, am i missing a bolt?

Posted: Tue May 12, 2009 11:15 am
by hansken_yo
Looks like there are 3 behind the pulley. did you get them all?

this is a photo of when I removed my 2.0l for my swap. I took the powersteering apart as one unit to contain the fluid.

you can see where the PS reservoir was hopefully this help a little.

Image

Posted: Tue May 12, 2009 12:20 pm
by danielc24
i WAS missing a bolt! got it out and have the new one on how do i put the belt on?

and what kind of fluid do i need?

Posted: Tue May 12, 2009 1:02 pm
by hansken_yo
i used redline powersteering fluid.... but any ol' brand should work fine.

Posted: Tue May 12, 2009 1:29 pm
by danielc24
ok the belt is on and im ready to add fluid. My car hasn't had power steering in 2 years atleast, do i just fill the resevoir and start the car or what?

Posted: Tue May 12, 2009 1:41 pm
by hansken_yo
I would lift the front end off the ground, unlock the steering but do not turn it on and slowly turn it back and forth so that the fluid gets worked through the pump manually. You'll need to watch your fluid levels at this point too because the reservoir will need to be refilled. Once it looks like you don't need to fill it anymore you should be ready to turn the car on and drive it around. Check the fluid once more after that and top off if needed.

Posted: Tue May 12, 2009 1:44 pm
by danielc24
cool, thanks for the quick replies

i just noticed my tensioner is moving alot is this normal while the car is running?

Posted: Tue May 12, 2009 6:37 pm
by danielc24
I forgot how nice it is having power steering lol

Posted: Tue May 12, 2009 9:12 pm
by hansken_yo
:thumbup: