NGCturbo project log: finally a video

Do you have a project going or will you be starting a project here very soon and just want to keep a log of everything you and when? Share with everyone every step of the way what sort of progress you are making on your project.
User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Mon Sep 03, 2012 10:59 pm

Ah I kinda figured somethin like that. So ill just leave it where I put it lol
Sorry for Party Rockin
Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11781
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Post by MyNeonSaysHi » Mon Sep 03, 2012 11:49 pm

Usually plugs right into the intake.
Can't go wrong with a stock intercooler. Best intercooler out there IMO. Little to no pressure drop and it's light as hell. So the turbo install has begun since you have the intercooler on?

08 Acura TL-S
05 Neon SRT-4

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Tue Sep 04, 2012 12:12 am

Uh my iat is plugged into my intake. Thus sensor is somethin else actually.

Yea its kinda starting :) I'm just installing things that I can while still driving it daily. I just plugged the intake holes for now. I plan to do a weekend build where ill finish everything

I'm glad to hear its a good intercooler. It's a little beat up.
Sorry for Party Rockin
Image

User avatar
fargo59
2GN Member
Posts: 118
Joined: Sat Nov 19, 2011 9:05 pm
Location: niagara falls ON.

Post by fargo59 » Tue Sep 04, 2012 12:32 am

most NGC vehicles have both an AAT and an IAT.
the sensors are similar, since they do the same job. one tells outside air, reports it for cold start, charging ability, and such, along with overhead console temp readout on vehicles with such consoles.

intake air temp tells the ngc what the actual intake temps are, which correlates to how the fuel will atomize

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Tue Sep 04, 2012 12:38 am

Ok That's wat I thought u were sayin earlier I just got confused about the intake comment. Thank you!
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Sep 08, 2012 1:45 am

More parts came in today :) I'm still waiting on some parts from asp tho :( ordered like a month ago wen I ordered the turbo.

I got a slightly used boost solenoid and turbo timer

Image

And also...

Image

3" mandrel bends and flanges to fab up my exhaust :)
Notice the oem radiator in the background? Ya I cracked mine years ago wen my hood met the bumper of a Toyota pickup :banghead: finally gotten around to replacing it lol

Also got a little done today. I installed the turbo timer and a bit of the lc-1

Image I followed instructions on SRT 4 forums and quite honestly I have no idea why this works but it does. Just soldered green on terminal 9 of my interior fuse box and the red to terminal 14. Then black to ground.

There is a lot of wires that go directly to battery and a lot that share a ground so I used a terminal strip and jumped a few terminals to splice everything together. + on one side - on the other. All I gotta do now is solder the main power wire to my fusebox. I'll be able to add other things to it easily as well.

Image
Sorry for Party Rockin
Image

ThatKevin
2GN Member
Posts: 1176
Joined: Wed Aug 03, 2011 12:48 pm
Location: Brampton, ON

Post by ThatKevin » Sat Sep 08, 2012 8:37 am

so close my friend, so close.

very jelly
Image
'02 Chrysler Neon RT - SOHC 50trim+Crane 007 ---DEAD---
'05 Dodge Neon SRT4 - DSP & bolt ons ---SOLD---
'08 Dodge Caliber SRT4 - MS1Kv3
Progress Log

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Sep 08, 2012 10:54 pm

:thumbup:
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Sep 22, 2012 2:49 am

Got a few things done this week.

Installed new radiator. Installed led 3rd eye tailight and mounted my catch can. There is a good spot for it right on the top right radiator bracket. Still need to run the vac lines to it tho.

Also took off my exhaust and measured it all then cut my new piping. Just need to tack it and make sure it all fits then weld it together.

Ordered a few parts also including: 3 pod gauge cluster, SRT 4 boost gauge with blue led, bov and turbo gaskets, gm weatherpacks, aem cone filter, a custom most badge and everything I need to build a ss o2 housing.

Hoping to get this build moving asap
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Sep 29, 2012 11:01 pm

Few more things done.

Got my gauge pod installed with a innovate wideband and SRT boost gauge.

Image

Haven't powered em up yet but the wires are run to power and ground locations.

Also I removed my exhaust awhile ago and started designing my 3" inch exhaust. Have it all cut just need to make sure it fits. Unfortunately I don't have easy access to a welder but it will be ready soon. I have the first section tacked together. So today after work I checked to make sure it fit. Like a glove! (Jim carry voice) It's perfect. I also marked where it needs to b cut to line up with the cat and marked the hangar.

Here is the pipe

Image

My plan is to build my cat back off of my agp ss 3" hiflow cat. then build the o2 housing to line up during my big weekend build.

I have a ss 3 inch 180 bend, a ss 3" 4 bolt flange from agp and a ss 3 inch v band flange.

I want to build this
Image

I also got gm weatherpacks to build my ms2 so it can swap easily back to obdII
Sorry for Party Rockin
Image

NyNeon0813
2GN Member
Posts: 727
Joined: Thu Nov 17, 2011 11:53 am
Location: ny

Post by NyNeon0813 » Sun Sep 30, 2012 10:28 am

Everything is coming together and looking awesome! Cant wait til I get a side project car to turbo! Keep it up man!
Image

'01 PEON - '01 R/T head swap.. Bolt ons & ksports

***tUrBo CoMiNg SoOn***

__________
Justin*

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 10:39 am

Thanks man I appreciate it
Sorry for Party Rockin
Image

User avatar
XxWhiteNeonxX
2GN Member
Posts: 2110
Joined: Sat May 15, 2010 6:23 pm
Location: Pittsburgh, PA

Post by XxWhiteNeonxX » Sun Sep 30, 2012 10:41 am

dont you have an s256 with the .70 a/r Or am i thinking of somebody else?
Image
Haganracing wrote: Love you Cody, even if you fail in life <3
Leighvi424 wrote:omg cody i think u gave me a woodie :P
2004 dodge neon-300whp and counting

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 10:48 am

Yup that's me :)
Sorry for Party Rockin
Image

User avatar
XxWhiteNeonxX
2GN Member
Posts: 2110
Joined: Sat May 15, 2010 6:23 pm
Location: Pittsburgh, PA

Post by XxWhiteNeonxX » Sun Sep 30, 2012 10:51 am

NGCnoproblem wrote:Yup that's me :)
what v band did you go with and does it fit properly or just " close enough" because on the build we're working on now, the efr v band which was reccomended to us, did not fit properly and we had to toss it.
Image
Haganracing wrote: Love you Cody, even if you fail in life <3
Leighvi424 wrote:omg cody i think u gave me a woodie :P
2004 dodge neon-300whp and counting

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 10:53 am

Y didn't it fit? I need to go check and make mine does now that you mention it. I honestly just got one of the nicer ones on eBay
Sorry for Party Rockin
Image

User avatar
XxWhiteNeonxX
2GN Member
Posts: 2110
Joined: Sat May 15, 2010 6:23 pm
Location: Pittsburgh, PA

Post by XxWhiteNeonxX » Sun Sep 30, 2012 10:57 am

NGCnoproblem wrote:Y didn't it fit? I need to go check and make mine does now that you mention it. I honestly just got one of the nicer ones on eBay
the weld on v band was too large, thickness wise.

Say for instance, the allowable distance in the v band clamp is 1" ( hypothetically) and once the two v bands are mated together, the thickness exceeds that. Thats the problem with the efr v band flange.
Image
Haganracing wrote: Love you Cody, even if you fail in life <3
Leighvi424 wrote:omg cody i think u gave me a woodie :P
2004 dodge neon-300whp and counting

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 11:03 am

Well after lookin at mine I think mine won't work either... The outside diameter of the lip isn't big enough. The v band on my turbo is a little bigger. With the vband clamp tight on the flange and the turbo the flange has play...
Sorry for Party Rockin
Image

adxavier06
2GN Member
Posts: 74
Joined: Tue Oct 04, 2011 2:27 pm
Location: houston tx

Post by adxavier06 » Sun Sep 30, 2012 3:14 pm

Im liking the progress!!! I been driving my boosted SOHC for a few weeks now and runs really good at 15lbs. Erick got my car lined out very nice.
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 3:25 pm

My bottom end will not b ready for 15 lol. But someday....
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Sep 30, 2012 11:18 pm

Gauges are powered up. Wideband read 20.9 so its running perfect! On warm up it flashes 7.4 which is kind of irritating lol.

Image
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Tue Oct 02, 2012 1:16 am

Got stainless steel bolts and washes for my build

Image

So filthy!
Sorry for Party Rockin
Image

ThatKevin
2GN Member
Posts: 1176
Joined: Wed Aug 03, 2011 12:48 pm
Location: Brampton, ON

Post by ThatKevin » Tue Oct 02, 2012 8:58 am

looks dumb.

doesn't suit your car, send it my way
Image
'02 Chrysler Neon RT - SOHC 50trim+Crane 007 ---DEAD---
'05 Dodge Neon SRT4 - DSP & bolt ons ---SOLD---
'08 Dodge Caliber SRT4 - MS1Kv3
Progress Log

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Tue Oct 02, 2012 2:41 pm

Now that you mention it.... It totally doesn't look good with my car. I'll go to USPS later today XD
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Oct 13, 2012 1:05 am

Alright so the turbo build is goin really slow cus I'm still waiting on ms2. Ordered it a few months ago....

But today I welded up a lot of my exhaust. Still need to finish the last portion. Here it is so far

Image

Kinda wish I went with a side exit like nikki is doin

If I ever get this thing as built as I want too I have even better ideas :)

Also installed my prothane lower control arm and front sway bar bushings. What a pain in the ass...

Idk wat you guys usually do to be able to reuse your original sleeve on the rear bushing but I ended melting all the rubber off with a torch which worked quite well lol
Sorry for Party Rockin
Image

redneckmoparman
2GN Member
Posts: 185
Joined: Thu May 19, 2011 3:35 am
Location: Olympia, WA

Post by redneckmoparman » Sun Oct 14, 2012 3:52 am

Thats the usual method but your exhaust looks great! What size is it?

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sun Oct 14, 2012 11:13 am

Thanks man. 3 inch
Sorry for Party Rockin
Image

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Thu Oct 18, 2012 11:36 pm

So my ms2 is on its way finally!

Unfortunately still my be delaying the turbo build...
My other dd a 1990 Toyota pickup decided to take a shit at only 150000 miles. Until I can fix it I can't afford to risk my car breaking.

I did get a new hood tho
Image

The cf hood just didn't fit right.... I love this so much more.

Plans are to work in suspension and cosmetics until I can get the turbo build back on line.

Also replaced my rear brake cylinders. I'm in brakes this quarter and found one was blown.

New one
Image
Sorry for Party Rockin
Image

ThatKevin
2GN Member
Posts: 1176
Joined: Wed Aug 03, 2011 12:48 pm
Location: Brampton, ON

Post by ThatKevin » Fri Oct 19, 2012 6:45 pm

BOOOOO

buy a $500 beater?
Image
'02 Chrysler Neon RT - SOHC 50trim+Crane 007 ---DEAD---
'05 Dodge Neon SRT4 - DSP & bolt ons ---SOLD---
'08 Dodge Caliber SRT4 - MS1Kv3
Progress Log

User avatar
NGCnoproblem
2GN Member
Posts: 866
Joined: Wed May 09, 2012 1:32 am
Location: Buckley, WA

Post by NGCnoproblem » Sat Oct 20, 2012 12:58 am

My wife would b pissed lol. It's her car
Sorry for Party Rockin
Image

Post Reply

Return to “Progress/Project Log”