Page 1 of 1

Need help with stock CD changer

Posted: Wed Sep 12, 2012 5:09 pm
by freelancer1988
Okay, to make this simple and sweet... I have a stock 4 disc cd player and wanted to install the 6 disc changer... My problem is when I plug the 6 disc up... nothing happens... It has the same plug as my 4 disc as well. I was just wondering if it is not compatible with my 02 stereo?

No power seems to be getting to the 6 disc. I at least figured it would power...

I also found a good deal of corosion and a couple of pins in the back are kinda darker... That too may be my problem on the 6 disc... Hmmm...


Any ideas?

Posted: Wed Sep 12, 2012 7:10 pm
by mjrpaine
Sounds like a bad radio to me. I took the stock single cd player out of my 05 srt and put in an RB1 plug and play and it worked right away.

You might really wanna check those connections ...

Try to power the radio by by-passing the plug itself. Splice in another wire to the power and groud and connect it to a power source to see if the radio even works.

Posted: Wed Sep 12, 2012 7:43 pm
by freelancer1988
mjrpaine wrote:Sounds like a bad radio to me. I took the stock single cd player out of my 05 srt and put in an RB1 plug and play and it worked right away.

You might really wanna check those connections ...

Try to power the radio by by-passing the plug itself. Splice in another wire to the power and groud and connect it to a power source to see if the radio even works.
sorry. My radio works perfect. I am referring to the cd changer. My 4 disc cd works fine hooked to the radio, but my 6 disc does nothing. No lights or anything.

Posted: Wed Sep 12, 2012 9:43 pm
by sidepipe87
Is the changer dead? Does the radio light up ERR or anything?

Posted: Thu Sep 13, 2012 5:50 am
by freelancer1988
sidepipe87 wrote:Is the changer dead? Does the radio light up ERR or anything?
Maybe, not a damn thing. lol. I will be dismantling it and inspecting it for damage after work today.

Posted: Fri Sep 14, 2012 8:48 am
by Gnuserup
I swapped my 4-disc to a 6-disc and it´s working perfectly, so your changer might be defective

Posted: Fri Sep 14, 2012 1:02 pm
by freelancer1988
Gnuserup wrote:I swapped my 4-disc to a 6-disc and it´s working perfectly, so your changer might be defective
well dang.


I did pull it apart and it looks like 2,000 volts went into it. Everything on the bottom board looks like it got baked in an oven... Ugh... My bad luck, but it was free... so oh well. Looking for another one real soon.