How-To: Install Autostick shifter/ cluster * finally working

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Tue Aug 16, 2011 3:49 am

Wolfsburg? ~250 km
But Belarus is >1100 km :lol:

User avatar
TinyQ
n00b
Posts: 5
Joined: Thu Jul 21, 2011 8:48 am
Location: Belarus

Post by TinyQ » Tue Aug 16, 2011 4:24 am

My colleagues sometimes go on business trips to Germany. And I have an unnecessary cluster with autostick.

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Tue Aug 16, 2011 6:43 am

oho, that sounds great (for Gnuserup).
please tell us more!
Neon or PT cluster?
Black or grey gauges?
Mileage?
How much you wanna have for it?
Will your colleague come somehow to/through Berlin?

Please PM Gnuserup for the answers (selling things is not allowed in this section)!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Tue Aug 16, 2011 12:00 pm

That really sounds good to me.

If that would be the only way, Wolfsburg isn´t that far away for getting a neon autostick-cluster and I would enjoy this ride for sure :lol:

Tommyk
n00b
Posts: 9
Joined: Fri Sep 02, 2011 4:05 pm

Post by Tommyk » Thu Sep 15, 2011 1:07 am

I have a 2005 neon too does that mean i can just install that shifter then i have auto stick?? how does it work how do you switch gears. Id love to have control of the gears on my car

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Thu Sep 15, 2011 2:04 pm

unfortunatelly it´s not just the shifter ...

If you get it working at the end, you can ride with automatic as usual. If you shift from D to formerly "3" you reach the A/S-Position and here you can switch right or left to up- or to downshift nearly as you like.

Tommyk
n00b
Posts: 9
Joined: Fri Sep 02, 2011 4:05 pm

Post by Tommyk » Fri Sep 16, 2011 12:23 pm

what else would i have to get/do to make it work?

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Fri Sep 16, 2011 12:55 pm

read the whole thread and find out that there is still no solution...

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Sep 17, 2011 2:57 am

... to get it work without an autostick-cluster.

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Thu Dec 29, 2011 6:18 am

good news - at least for me :lol:

Image

All parts must be out of the same car, as the seller had just parts which had been declared out of a black neon. Because he had an autostick-shifter, the dob seemed right and he had no other stuff from different neons, I risked it.

Cluster, pcm, immobilizer and ignition barrel.

Image

Image

Image

Image

Sure - the first thing was to disassemble the cluster.
From the outside (except for the numbers) there seem to be no difference.
Just on the place where the LED for autostick is on the rpm-gauge you could notice a tiny difference viewing in a special angle (not possible for me to take that on a picture)

On the back of the plate is a second resistor which is missing on the usual. The rest is the same - I found no difference ( by comparing my both black uk clusters :D ).

Image

Image

Image

The part-number of the autostick-plate. On the non-autostick uk-plate its ...AL.

Image

The odometer-plate with autostick ( :rockon: ) - number of wires and plug the same as on the non-autostick.

Image

Image

The bezel is a bit different for the Autostick-Display

Image

For comparison the non-autostick-bezel on the picture below

Image

Image

Image

Image

Image

Image

Image



Special thanks to Dan who helped me out getting this stuff as the junkyard had not wanted to ship outside uk.

And special thanks to TinyQ who offered his support as well.

*** *** *** *** *** *** *** ***

The very next time I will try to plug the cluster with my selfmade OBD-Adaptor

Image

and will see what happen.

Then I will look for the red DOT on the cluster

Image

which came on on my last try with the other non-autostick-cluster last time (on the picture above).
If nothing helps - now I have the correct pcm for the autostick-cluster :lol:

Anyway - next time I like to get an PT Cruiser autostick-cluster to disassemble that thing and to try if it will work on the neon :tardbang:

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Thu Dec 29, 2011 8:09 am

geile Scheiße!!!

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Thu Dec 29, 2011 9:59 am

The (!) is for the parking brake, or if there is a fault with the brake hydraulics. Regular 140, and 160 mph clusters also have that issue when installed in the standard neons.

http://forums.neons.org/viewtopic.php?t=263363
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Thu Dec 29, 2011 2:30 pm

yes - and that is why I absolutely wanted to get an autostick-cluster AND the pcm out of the same car. I don´t liked the idea to solder something on the cluster to fix that damn light.

So I think I am very lucky to have found a set in autostick, NGC and miles.

***

Next step is to try the autostick-cluster parallel to see if that will work. Then - for warmer days - I´ll swap the cluster and the pcm.
Here I think the immobilizer out of the same car will help a lot for getting it work. Or do you know, what will happen, if I only swap the cluster and the pcm ?

The last step on this will be to get hands on a PT Cruiser cluster and see if this works, too. These cluster are a lot easier to get.

If all these things are finished - ABS is the next on my list :tardbang:

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Thu Dec 29, 2011 2:45 pm

IDK if the light is a result of the PCM's being different, or if it is a wiring difference. I have an R/T pcm, and an R/T cluster... :-k Maybe I should install the bulb, and see if it goes out. I believe I installed the cluster before the PCM. I have a bulb burn't out by the tach anyways...
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
TinyQ
n00b
Posts: 5
Joined: Thu Jul 21, 2011 8:48 am
Location: Belarus

Post by TinyQ » Fri Dec 30, 2011 1:25 am

These lamps are lit because there is no ABS in the car. With the DRBIII, you can disable this check.

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

working !!

Post by Gnuserup » Fri Dec 30, 2011 6:37 am

ok - or the next thing is to install ABS as well :lol:

***

Could not have been waiting to go on with the work, so I tried today :lol:

Took my Adaptor and connected the A/S-Cluster on my 2000 LE
(only Ground, B+ on 15 and PCI-Bus):

Image

This is what it looks like on my SXT:

Image

For comparison my non-A/S-cluster on the SXT:

Image

While the first two tests the display showed up the gears selected correctly, but then the cluster looked like the first picture above.

The wiring diagramma says PIN9 has to get B+, too on the A/S-clusters - so I installed that on my Adaptor and now it is working:

http://www.youtube.com/watch?v=hidudCSf ... er&list=UL

Long story short:

I took my Adaptor which routes ground, B+ and PCI into the parallel 2nd cluster (just for testing). On the A/S-cluster B+ on Pin 15 and 9, ground on 10 and PCI on 2.
Now I could shift as I like and the dispaly shows up the right gears including autostick and the gears from 1 to 3. While shifting from 1 to 3 I can hear the trany working.
Had not tested this thing driving, but am sure it will work as my SXT now behaves like the original autostick-equipped neon I had for a testdrive time ago.
Next is to wire it all up correctly and safe and install the other (A/S) PCM to avoid the brakelight lit.

Other thing I stay tuned is to try a PT Cruiser Cluster :thumbup:

:rockon: :rockon: :rockon:

User avatar
Danteneon
Former Moderator
Posts: 9591
Joined: Thu Dec 20, 2007 5:13 pm
Location: Manassas, VA

Post by Danteneon » Fri Dec 30, 2011 11:39 am

Nice work =D>

This is good info to have for sure.
If I could just figure out how to meld the Outback and the Neon into one car...

Image

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Fri Dec 30, 2011 11:51 am

Almost makes you want to go ATX, doesn't it?



::Quickly runs away::
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Danteneon
Former Moderator
Posts: 9591
Joined: Thu Dec 20, 2007 5:13 pm
Location: Manassas, VA

Post by Danteneon » Fri Dec 30, 2011 12:06 pm

:beatstick:

It does make me want to figure out how to make the indicator work with my MXT though. Well, at least for 4 of the gears :lol:
If I could just figure out how to meld the Outback and the Neon into one car...

Image

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Fri Dec 30, 2011 12:09 pm

This should not work - look on my 1st picture which shows the A/S-cluster connected on my mtx 2000. Otherwise you could get that A/S-odo and solder your own wires onto the display but then you have to find something to control that right.
Now we are back on the PT cluster - does no one have any PT cluster to tear apart and see what that odo looks like ?

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Fri Dec 30, 2011 12:30 pm

Glad I ran to avoid that beat down.

Glad John isn't far behind me in age, so he doesn't catch up. :lol:

You could make the MTX display the gears with some kind of switch arrangment at the shifter that is pressed when in that gear.

Figuring out how to translate that into the PCI bus code to illuminate the indicator would be the act of genius.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Fri Dec 30, 2011 12:55 pm

:hiding:

Any specialist in reverse-engineering here ?

Ok - then a good place to put an indicator in could be this on the non-A/S-clusters

Image

- something like this but a lot smaller and just one digit

link

*** ***

Found this here - very interesting I think: link to PT Cluster here

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Fri Dec 30, 2011 2:04 pm

A single digit display would work. Just need to program the chip for it. Could use different resistors, or something, to indicate what switch is what gear. Would work up to 9 speeds. :) Could use zero for neutral, if it won't display letters.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Danteneon
Former Moderator
Posts: 9591
Joined: Thu Dec 20, 2007 5:13 pm
Location: Manassas, VA

Post by Danteneon » Fri Dec 30, 2011 2:56 pm

:-k
If I could just figure out how to meld the Outback and the Neon into one car...

Image

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jun 08, 2013 9:10 am

:rockon:

Now it is proofed:

a PT Cruiser Cluster should work in a neon

http://www.youtube.com/watch?v=zUtMCVsM-a4

and a PT Cruiser Autostick Cluster works in a Neon SXT ATX making Autostick functioning

http://www.youtube.com/watch?v=MktIKfW53Ys

Many thanks to Neil from SRT-Forums helping me to get a us-PT Cruiser Cluster with Autostick :thumbup:

What I did: getting my selfmade OBD to whatever-Adaptor, wiring up the black 26-pin plug to the needs of the PT Cruiser Cluster and connected.
So as we learned time ago, two clusters will work parallel.

It threw me a code P0462 for low fuel level sensor ( as well as it did when I tried the neon autostick cluster), but I´m sure, if wiring up that, too or installing a resistance for the input on the 2nd cluster will fix it.

I wired a regular PT Cluster first, just on the black 26-pin-plug Pin 1 ground, 14 B+, 26 PCI - all from OBD

worked

then the Autostick-cluster - nothing :tardbang:

remembered on the neon-autostick-cluster I had to connect two more cableshoes. So started to search for a PT Cruiser 2004 wiring diagramma. Result: connected Pin1 and 2 with ground, 14 and 15 with Power and 26 PCI - working

(Don´t forget, you need the Autostick-Shifter be connected to the shift-up and shift-down pins on the PCM AND power the shifter, too.

Maybe you should be able to use any kind of momentary switch and have your standard-shifter in (3) - but that is not proofed yet.

By the way - the PT Cluster has a 2nd (white 8-pin) socket for :

1 - fog lamp switch output
2 - VTSS indicator driver (what´s that ??)
3 - empty
4 - empty
5 - empty
6 - rear fog lamp switch output
7 - panel lamps dimmer signal
8 - empty
9 - fuel level sensor signal (use this next time)
10 - empty

Will post some pictures of the PT cluster (and disassembling it) soon.

So now feel free to upgrade to autostick easylie.
Get you a PT Autostick Cluster and use it as a Autostick-dongle while keeping your regular cluster installed.

Other thing might be to build up a custom cluster with a PT Cluster instead of the neon-cluster :D
a neon - what else ?

occasional demons
Junior Admin
Posts: 19011
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Sat Jun 08, 2013 6:10 pm

:thumbup: :rockon:

Good work!
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sun Jun 09, 2013 6:23 am

got it - I don´t wanted to wait any longer and made a test drive with the PT Cluster parallel

Sorry for the crappy videos, but I unfortunatelly had only two hands (one for the camera, one for shifting...)

http://www.youtube.com/watch?v=H_p7MulB ... e=youtu.be

http://www.youtube.com/watch?v=oTr8H7kB ... e=youtu.be

And here is what the trany is doing:

Normal behavior in "D", Autostick in "Autostick" - means shift from 1 to 4 like you ever like and back.
4 only at speeds more than 15 or something.
Shift up to 4 at speed pretty earlier than "D" would do.
If you are in 4 or something higher than 1 and are slowing down or stopping it shifts down itself down to 1. When going to accelerate YOU HAVE TO shift up yourself manually again.

Now have to fix the code and further noticed, that the radio display flashes, when 2nd cluster is on.

Oh - btw. you have to attach the 2nd cluster before starting the engine :D

*** Would love to read from now on less "help - I want to go MTX" and more "help - I´m going to keep my ATX and make it Autostick" - Projects :rockon: ***
a neon - what else ?

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Sun Jun 09, 2013 9:01 am

and now you need some steering wheel paddles like in Formula 1 instead the autostick shifter...

wickedgood4684
2GN Member
Posts: 312
Joined: Sat Aug 14, 2010 5:30 pm
Location: Lisbon Falls, ME

Post by wickedgood4684 » Sun Jun 09, 2013 9:23 am

Image
SRT-4 Challenge series
Season 1 Champion: gotheframe/tim and corey
Season 2 Champion: Greasydeuce/Dmonday
NTCC
Winter Series:
Drivers Chamion: Neon Nick/Squat BIG
Team Champions: Team Acura: miniMench & wicked221
Rookie of the year: Patriot 01/xxPATRIOT 01xx

Blackguy503
n00b
Posts: 17
Joined: Tue May 14, 2013 2:49 pm
Location: Portland, Oregon

Post by Blackguy503 » Sat Aug 24, 2013 12:18 am

this is awesome just wish I understood all that wiring stuff said in here
...."Because racecar."

Post Reply

Return to “HT Electrical”