P0301 and flashing cel

Is your car throwing codes or are you having a hard time passing your state or county emission test? Ask how to fix it here.
Post Reply
millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

P0301 and flashing cel

Post by millerwelder » Sun Jan 19, 2014 7:50 pm

On my way to work the other day the cel started flashing. I didn't know any better so I just kept going. Finished work drove home flashing the whole way. My commute is abt 70 miles each way. When I got home I searched and found the flashing cel to be super bad. Checked codes and P0301 popped up. Thing is it isn't running funny or anything no hiccups, no stalling nothing. It does idle rough (as in a ton of vibration but the tach stays in the exact same spot) but I think it's due to the mounts being shot. Ideas?

p.s. sorry if this is in the wrong spot, and I searched but couldn't find much. everyone else's car was running like crap.

occasional demons
Junior Admin
Posts: 19108
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Sun Jan 19, 2014 8:07 pm

It is the misfire code for number 1 cylinder.

You either have a bad plug, wire, oil in the spark plug tube, from the tube coming out of the head, an injector not up to snuff, low compression, vacuum leak at #1 port/injector o-ring, bad lash adjuster/rocker, cam lobe or valve spring.

It may not be a hard misfire, but enough that the crank speed is fluctuating consistently at #1 firing position. The PCM monitors the crank speed via the crank sensor. It can detect the changes in speed to determine if there is a misfire.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Mon Jan 20, 2014 5:46 pm

Thanks, I forgot to mention it started this after adding seafoam to the tank (it sat for a year with a 1/4 tank in it). Probably just coincidence but I'll start with the plugs then check resistance in the wires and replace as needed. Also, aren't the coil pack harnesses prone to failure from rubbing? I'll check that too. I'm scared to check compression lol

occasional demons
Junior Admin
Posts: 19108
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Mon Jan 20, 2014 6:25 pm

You could try swapping #4 plug and wire to see if you still get a P0301, or if you get a P0304. If the code stays at P0301, then it is not the plugs/wires.
You will need to reset the PCM before restarting the engine to clear the code, otherwise it will keep the P0301 regardless.

It then could be a partially clogged injector. There may have been varnish that formed in the fuel lines from sitting. The Seafoam could have broken it loose, and it is working it's way into the injectors.

There is a small screen in the injector inlet. It can be cleared of debris, but you need a compressed air source, a rubber tipped, or regular blow gun, a spare EV6 injector connector, and enough wire lead to connect to the battery.


With the injector energized, blow the air from the bottom, and be careful of the fuel/debris blowing out the top. I had to do this on my '99 and my GF's '94 Sundance.

The Sundance was really bad, It developed a soft multiple misfire after a few days, due to the engine I had installed had sat for 12 years, and the ancient fuel in the fuel rail had really varnished up badly. Once I flushed everything out, and blasted the crap out of the injectors, all was good again.

Injectors for the older neons/Sundances are $50 each, so for 6 of them, I was willing to get creative and salvage them if at all possible. The car was barely worth dropping the engine into, and I wasn't enthusiastic about dropping another $300 plus tax into it.

I did eventually have to replace the neon's injectors, as their weakness showed itself with the 2.4 swap.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Mon Jan 20, 2014 10:06 pm

Thanks for the info, I unhooked the battery turned the headlights on let it sit for an hour or so. Next I pulled the plugs. Not so good Al- definitely the factory plugs (car has 108,000) found out the tubes on #2 and #3 are leaking. NBD cheap and relatively easy. Put new plugs in took it down and filled the tank. Next I ran the dog piss out of it up and down 71 and so far it runs better and the cel is off. I'll take it to work tomorrow and see if it stays off. Wish me luck!

Edited to add p.s.

P.S., I'll try to post a pic of the plugs tomorrow, it's been a while since I've seen plugs this rough.

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Tue Jan 21, 2014 5:03 pm

I know everyone is on the edge of their seats waiting to hear how it went... lol 140 miles today no cel! Woot! I'm kinda disappointed though b/c I thought I'd have an excuse for the missus on why I needed to do headwork lol Thanks for all the help guys!

A@ron
2GN Member
Posts: 31
Joined: Wed Jan 01, 2014 1:12 pm
Location: Fort Wayne, IN

Post by A@ron » Tue Jan 21, 2014 6:03 pm

I want to see the condition of the plugs :lol:

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Tue Jan 21, 2014 10:05 pm

As soon as I make it out to the garage to snap some pics I'll try to figure out how to post them :)

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Wed Jan 22, 2014 9:14 pm

Image

Image

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Wed Jan 29, 2014 11:02 pm

Ok... so the dang flashing light is back :/ So when it warms up this weekend I'll be changing the valve cover gasket, as well as the granatelli wires and coil I ordered from MP. Thinking I might as well get the dreaded compression check out of the way too. My question is if the compression turns out ok, and it ends up being an injector- is there any benefit to going a little bigger? Which Accel injectors would be good for a mostly stock engine (CAI, full exhaust)

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Thu Jan 30, 2014 12:34 pm

Anyone out there..... lol

05MoparSRT4
2GN Member
Posts: 110
Joined: Tue Dec 10, 2013 6:21 pm

Post by 05MoparSRT4 » Thu Jan 30, 2014 5:27 pm

Correct me if I'm wrong....but I do believe if you get bigger injectors you're going to need a bigger fuel pump. Even though you have bigger injectors you still have the same amount of flow coming out so you'll essentially be just dumping fuel. With bigger injectors I BELIEVE you need a tune and a better fuel pump. I THINK not 100% but close to 100%
Image

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Thu Jan 30, 2014 5:51 pm

ok, thanks for the heads up! :) What accels are equivalent to stock?
I don't mind the $ because you can get a whole set cheaper than you can get one for my truck lol

05MoparSRT4
2GN Member
Posts: 110
Joined: Tue Dec 10, 2013 6:21 pm

Post by 05MoparSRT4 » Thu Jan 30, 2014 6:21 pm

I'm not sure what accel is. are you refering to accel coil pack? if so I'd stick with the stock coil pack. At least for an SRT. They're better IMO than Grantelli and especially MSD
Image

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Thu Jan 30, 2014 7:12 pm

MP sells accel injectors, I'm just trying to figure out which are the stock flow rate searching isn't getting me very far :/ Wish there was a chart or they said "if your looking to replace stock with stock flow rates you need these" lol

05MoparSRT4
2GN Member
Posts: 110
Joined: Tue Dec 10, 2013 6:21 pm

Post by 05MoparSRT4 » Thu Jan 30, 2014 7:18 pm

what year is your car?

*EDIT*

Found this in a different section of the forums
viewtopic.php?t=21657

Taken from SRT4 Fourums:

"Yes. There is a formula for it. It is as follows:



Injector Flow Rate (cc/min) =
Engine HP x BSFC x 10.5
Number of Injectors x Injector duty cycle



BSFC (Brake Specific Fuel Consumption) varies depending on the type of induction. Here's a breakdown:

* For naturally aspirated engines, estimate BSFC to be 0.4 to 0.5
* For nitrous engines, estimate BSFC to be 0.5 to 0.6
* For forced induction, estimate BSFC to be 0.6 to 0.7
* For rotary engines, estimate BSFC to be 0.6 to 0.7
* For engines running methanol, double the appropriate gasoline BSFC (e.g. a forced induction methanol engine has a BSFC between 1.2 and 1.4)


Injector duty cycle should be around 80%, so where the equation asks for duty cycle, use .8 for the value.

example: 400 Hp Turbocharged 4 cylinder

400(HP)*.6(BSFC)*10.5=2520
4(injectors)*.8(duty cycle)=3.2

2520
3.2 =787 cc injectors

(note: The equation bases calculations off of an assumed fuel pressure of 43.5 psi. Different fuel pressures will result in different needs in injector size.)

Now you must remember that all this is theoretic, so it has margin of error. It's absolutely possible to achieve 400 HP+ on 750cc injectors, and has been proven time and time again. In fact, I believe it's been done with 650 cc injectors, but usually requiring higher duty cycle, and higher fuel pressure. So take all this theory with a grain of salt."
Image

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Thu Jan 30, 2014 7:40 pm

Ok, that's a lot of info lol Maybe this will help- today, I changed the valve cover gasket and repaired the spark plug tubes. Problem is, the one that is having the misfire issue is the only one (tube) that wasn't leaking. When I pulled the plug it was black with carbon. Is this a sign of a stuck or otherwise messed up valve or is it pointing to an injector? It's a 2003 SXT btw

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Fri Jan 31, 2014 6:28 pm

Well.... The dreaded compression check is over..... No compression on the #1 cylinder :/ I've priced out the parts to completely rebuild the head as well as timing belt, gaskets, water pump, tensioner, cam ect. and it was $1500 plus I'd still have to pay the machine shop. Then the bottom end would need to be addressed bc I'm sure that the walls probably got washed down from the unburned fuel. I looked in there and it was suspiciously clean... So my little buddy will be getting sold and hopefully when I'm done working this outage someone on here will have a cool neon that my fiance'/accountant will approve of me adopting. This plus the phone call from the ford dealer telling me I'll have an $800 bill waiting when they can find time to replace my leaking injector o rings has made this one of the crappiest days I've had in a while. I LOVED that little car and the fact that it brought me back to my happy just got my license days. Oh well wasn't meant to be I guess :/ Thanks for all the help anyways :)

p.s. funny thing is it runs really good, pulls hard and is decent on gas. You'd never know anything was wrong with it if the CEL didn't flash :wtf:

occasional demons
Junior Admin
Posts: 19108
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Fri Jan 31, 2014 6:50 pm

Well if it weren't for the $800 bill....

http://www.ebay.com/itm/391-BRAND-NEW-D ... 75&vxp=mtr

IDK if they have both SBEC and NGC engines, or are just ignorant. I messaged them a while back, but got no response.

No need to dump $1500 into a head, when there are reman's available for about 15% of that amount.
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Fri Jan 31, 2014 11:26 pm

evil temptor! lol

occasional demons
Junior Admin
Posts: 19108
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Sat Feb 01, 2014 11:24 am

Well the one pictured is an SBEC engine, so it won't run with your PCM. Way to much effort/expense to make it work, and you would never pass emissions, or be able to sell it, without the fear of the next owner coming back on you.

(Under Federal EPA laws, the next owner can make you fix the car so it is emissions legal)

If I so desired, I could have made the life of the last official owner of my '99, a living hell. The car changed hands ??? times from when the title was signed to when I got it. Being as how I bought it from an Ohio resident, and it was an Indiana title, with a different person's name on it...

(One reason why you have the buyer's info also listed when Notarized.)
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

Ramroid
2GN Member
Posts: 428
Joined: Wed Feb 22, 2012 1:24 am
Location: Kentucky

Post by Ramroid » Sat Feb 01, 2014 10:19 pm

I had the same thing happen when i replaced my fuel pump. Mine was caused by a fault seating of the plug wire onto the plug. Threw the code at me. Are the plugs being fully seated? just my 2 cents

millerwelder
n00b
Posts: 17
Joined: Tue Dec 31, 2013 6:07 pm
Location: Cincinnati,OH

Post by millerwelder » Sun Feb 02, 2014 9:07 pm

Thanks for the info guys, I started another thread with more info here- viewtopic.php?t=67300

Pretty sure it's a stuck or bent valve, zero compression on the #1 cylinder :/ Debating selling it and if there's a cool car in the classifieds after I get this outage out of the way picking it up. (like the white ACR.... Soooo dreamy,lol) O'reilley's had a complete rebuilt head (see other thread) for $450 but I've had a lot of people tell me that's too much $ and I can get a junkyard head, have it machined put new seals in it ect. for cheaper. If that was the case couldn't I just use my head and replace the valve? I was thinking $450 for a head rebuilt, tested and a warranty was pretty good. I don't know how much machine work costs but I figure between that, the actual cost of the head, seals and whatever other parts I'd need I'd be around the same price without the warranty and wondering when the other used stuff would break. Also, I'm confidant in switching the heads but not so sure I wouldn't mess anything up rebuilding the head. On top of all that, I'm relatively new to Cincinnati and don't have any friends to help and my neighbors while awesome can't even change a tire. So working within my comfort level and skill set I'm leaning towards the o'reilly's head or just selling it for what I have in it.

User avatar
INVUJerry
2GN Veteran
Posts: 6472
Joined: Mon Nov 21, 2005 9:55 pm
Location: Pasadena, MD
Contact:

Post by INVUJerry » Sun Feb 02, 2014 9:20 pm

I'm sure you could score a working head cheap. Look on the 2gn Facebook page or on Craigslist for parts.
Image
So many neons so little time.

Post Reply

Return to “Emissions”