2003 SRT DD

Do you have a project going or will you be starting a project here very soon and just want to keep a log of everything you and when? Share with everyone every step of the way what sort of progress you are making on your project.
User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Wed May 01, 2019 3:08 pm

The dealership says the noise is coming from the transmission because the fluid is too low. They say the driver's side axle seal (the new one that I replaced) is leaking. It sounds like a bunch of bullshit to me. I've heard what a low fluid trans sounds like and it's not this sound. Why would the noise only be heard out the passenger window if it was coming from the transmission, which is on the left side of the car? Why is my brand new Mopar seal (that went in without any issues) leaking already? The whole thing is fishy. I told them to top off the trans fluid and let me come get the car. I'm going to pick it up tomorrow and check it out for myself. I'm willing to bet a million bucks that, even with a full transmission, the noise will still be present because it has nothing to do with the transmission. Apparently I need to pull the axle and replace the seal again. Maybe I'll throw in the stock axle to see if the new one isn't sealing properly.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Wed May 01, 2019 4:23 pm

Weird pretty easy to check tranny fluid level. Just pull off rubber plug and the fluid should be right near the top of the fill plug. I need to check mine for the heck of it. Wish you had a video of said noise. You should make sure your tire isn't rubbing on something either.

So they are saying the axle seal your replaced is leaking. That sucks. They got to go in very carefully I know that and if damaged when going in can ruin them.

Here are some threads that might help, just random info and opinions:

https://www.srtforums.com/forums/f163/r ... lp-645664/

Good to know you can bend that piece and it won't leak:
https://www.srtforums.com/forums/f213/a ... nt-640305/

Says to use a bead of black RTV around the seal. I never did but it might help.
https://www.srtforums.com/forums/f213/axle-seal-606246/

This is the how-to I used a long time ago when I did mine on the silver SRT-4
https://www.srtforums.com/forums/f75/ho ... nt-598967/

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Wed May 01, 2019 4:36 pm

Thanks, man. I've read every one of those links already. I researched the hell out of this. I installed the seal exactly how they said to and it went in perfectly on the first try. I don't know what's going on. Maybe those cheap axles aren't sealing properly. Who knows at this point.

The noise sounds like the front brake is dragging just a little bit. It's really faint and high pitched at this point. It oscillates proportionately with vehicle speed. Definitely not the whine of an empty transmission. The fluid was really low on this trans when I bought the car because the end plate leaked like crazy. I know what that sounds like and this is not it. This car is fucking cursed.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

occasional demons
Junior Admin
Posts: 19495
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 SRT DD

Post by occasional demons » Wed May 01, 2019 10:31 pm

The bearings can also rattle in the trans with low fluid. But yeah, I have never heard anything like you describe from low fluid in an MTX.

The oscillating sound might be from a CV joint. Or possibly from tires. Swapping wheels around might eliminate it, if it is tires creating a weird harmonic sound.

The winter tires on my Impreza were making some odd oscillating sounds. The noise went away when I put the summer tires back on. After replacing a halfshaft, and then a wheel bearing this winter, I was getting nervous, as it is fast approaching 200,000 miles on the original parts, and this car was badly abused before I bought it, which can't help matters. Thankfully the tires solved that sound. The winter tires are going to be marginal for another season anyways.
Bill
dblsg wrote:ya'll a bunch of post whores
Seriously people, this is 2019 not 1920.
2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Mon May 06, 2019 4:00 pm

I don't know about you, but I don't think that looks like a leaking seal. The trans is obviously weeping from the seams, but not enough to drip anywhere. The moisture below the seal looks like remnants of the fluid that poured out when I removed the axle about a hundred miles ago. The axle itself is dry. I think the dealership was full of shit. The noise is still there.

Image
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Thu May 09, 2019 12:37 pm

P0340 and the car won't go over 2200 RPM. Looks like it's time for a new CPS and probably the magnet while I'm in there. Never a dull moment. Good thing I have a backup vehicle.

There's a lot of research out there for this code. I'm going to play it safe and replace both the cam sensor and the magnet. I'm also going to clean up all of the engine grounds around the sensor and reset the computer. I hope that all of these known fixes done together will be enough to do away with this issue on the first try.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

Midnight_Rider
2014 Platinum Contributor
Posts: 8113
Joined: Wed Aug 02, 2006 2:49 am
Location: Indianapolis, IN

Re: 2003 SRT DD

Post by Midnight_Rider » Thu May 09, 2019 12:52 pm

My CPS went out years ago the day after driving back from a meet at chipdogg's in WI. Good thing- I would have been stuck on an interstate somewhere in IL otherwise. CPS was replaced under warranty but I also had the magnet taken care of as well after others here suggested it. I'm still appreciative of the advice given me on that one.
Official "I'm Going To Drive My Neon 'til It Dies" Club #10

occasional demons
Junior Admin
Posts: 19495
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 SRT DD

Post by occasional demons » Thu May 09, 2019 2:36 pm

Unless the engine shut off, the cam sensor won't leave you stranded. The PCM just fires the injectors in batch mode vs sequential. For future reference, if it did kill the engine, you should be able to unplug the connector, and run in batch mode. It is very simple to get to on DOHC engines, so knowing that could save you an expensive tow bill. The only year that will not run with the cam sensor unplugged is 1996.

My guess is they limit it to ~2000 rpm, so you will fix it, and just not ignore the CEL, as we know 70% of the masses will. The only advantage to sequential is better idle and low rpm quality. Once the engine is spinning above ~1500 rpm, there isn't enough time for the fuel vapor to sit around in the ports to really matter. Basically they are holding your performance as ransom, so you'll service it.

Kind of like Subaru disabling traction control, hill climb assist, and a few other things on an MTX, because the reverse light switch fails. If it can't sense the gear, it won't do squat. It will otherwise drive fine, but you'll have no "perks".
Bill
dblsg wrote:ya'll a bunch of post whores
Seriously people, this is 2019 not 1920.
2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Wed May 15, 2019 2:46 pm

Yeah your seal looks fine to me. As for your Cam Position Sensor. Do it right the first time. Mopar magnet and sensor. Buddy did the autozone adventure with the sensor and it kept going bad. As others I have read.

Mine went bad on a previous SRT-4, I could still drive it but couldn't go over a certain RPM. Sucks because I was on the interstate too. Forget what speed I had to max at. I think it was like 50 something in 5th gear.

I say if you took your car to a shop and they were supposed to find the noise and you spent your hard earned money to have them diagnosis it. I say take it back to them! Unless you don't want nothing to do with them and move on. Any leads on what it could be?

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Wed May 15, 2019 5:07 pm

Mopar sensor and magnet have been ordered from Modern Performance.

I'm done with the dealership drama. They don't know what they're doing and I don't trust my car with them anymore. They gave me a huge clue when they tightened up the brakes and made the noise quieter. I'm going to replace all four rotors and pads soon, so we'll see if that makes a difference.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Sun May 19, 2019 2:30 pm

Magnet and sensor installed. I cleared the code with my OBD2 reader and all seems well again. You know, other than the random noises and leaks.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Tue May 28, 2019 10:27 am

I swapped over a 2004 valve cover this weekend. I installed a new PCV valve and replaced the hard line that goes from the valve to the intake manifold. I replaced it with 3/8" rubber hose, so it's no longer a hard line.

Image

The vacuum hose on the other side of the valve cover was cracked and falling apart. I tried to replace it with the same 3/8" hose, but I couldn't get the hose to go over the opening in the airbox. I capped it off for the time being. I hope there's no ill effects from doing so.

Image

I noticed a strange whine at idle after the vacuum line installation. It has to be related. I'm going to try to replace that second breather line to see if that helps.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Thu May 30, 2019 3:22 pm

Yeah I wouldn't cap that valve cover breather. Atleast just put a 3/8'' fuel line and dump it to the ground. Or a little filter or just leave it open. Better then closed. Just oil vapors come out of it in boost. Pretty much it.

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Thu May 30, 2019 5:23 pm

I managed to squeeze a 3/8" hose on it yesterday. The connection at the airbox is pretty weak, but it will at least vent out of the cover for now. The hose connection on the check valve wasn't air tight and I think that's where the noise was coming from. I doubled up on the zip ties and it seems to have helped.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Sun Jun 02, 2019 1:00 pm

Have you boost leaked tested the car yet?

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Mon Jun 03, 2019 12:53 pm

No, not yet. I want a second set of eyes to watch the boost gauge while I test it. I just haven't had the time or the help to do it yet. I can't wait to fix it, though. 12lbs on a Stage 2 car feels like a stock SRT.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Mon Jun 03, 2019 2:41 pm

I have a boost leak tester with a boost gauge t-d into the plastic fitting that the coupler goes on. Makes it easier. Had it for over 10 years now. DasMopar on SRTforums used to make em, I can take pictures of it and PM you if interested and maybe you could make the same thing.

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Tue Jun 11, 2019 11:08 am

So I peeled the Plastidip from two of the wheels over the weekend. I think it looks pretty good.

Image

Image

Image

I'm going to peel the other side when I have time this week.

I also painted the injector cover. It's not finished, but this is the first step. Call me weird, but I've always liked the aesthetics of dripping blood. Maybe it's my appreciation for horror movies...I don't know. The rear diff cover in my Jeep is painted the same way. Maybe it's an homage to Maximum Overdrive or Christine. It's not for everyone.

Image
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

occasional demons
Junior Admin
Posts: 19495
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 SRT DD

Post by occasional demons » Tue Jun 11, 2019 12:06 pm

I like the non plasti dip version better.


Nothing like a bloodthirsty SRT-4!

Maybe some slashed other make's emblems on the flat part, bleeding out....

Or it could go all cannibal, and have a 1gn on there. :shock:

:lol: :lol: :lol:
Bill
dblsg wrote:ya'll a bunch of post whores
Seriously people, this is 2019 not 1920.
2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Fri Jun 14, 2019 10:39 am

I peeled the rest of the Plastidip yesterday. No more red wheels.

I also, for the first time, heard the boost leak this morning. I did a full throttle pull through first and second. I could actually hear the air escaping somewhere. That's a good sign that only one place is leaking and I should be able to find it. I really, really need to boost leak test this thing. Maybe I can make it happen this weekend. Maybe.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

blueneo03
2GN Member
Posts: 1167
Joined: Mon Feb 02, 2009 4:46 pm
Location: Little Rock, AR

Re: 2003 SRT DD

Post by blueneo03 » Wed Jun 19, 2019 10:39 am

man i like the contrast on the wheels better with them in silver. also with the injector cover, are you going to paint the letters? i think those in a black or silver or something would look great against the dripping paint.
Image

2003 neon se crashed
1998 neon highline Sold
2005 neon sxtSold
2017 Volkswagen CC Rline Exec. 2.0t


"Sorry you are so scared of a possible mechanical problem that you will drive an ugly transportation appliance. I'll keep living a colorful life." -some guy about a camry

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Wed Jun 19, 2019 11:57 am

I'm one step ahead of you. They're silver, but they look kind of white in the picture.

Image

Next, I'm going to clear coat over it all. Ideally, I'd have a red valve cover to complete the look.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

occasional demons
Junior Admin
Posts: 19495
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 SRT DD

Post by occasional demons » Wed Jun 19, 2019 12:11 pm

You'll want to use clear with hardener in it. Otherwise it will yellow, or flake off eventually from the engine bay heat.

I used wheel clear coat, which help up for a few years, but it is showing it's weaknesses.
Bill
dblsg wrote:ya'll a bunch of post whores
Seriously people, this is 2019 not 1920.
2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Wed Jun 19, 2019 12:50 pm

A buddy of mine painted his 4G63 valve cover silver and used a regular clear coat on it. It turned gold in a matter of days. I'll definitely look for something meant for high heat applications.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

occasional demons
Junior Admin
Posts: 19495
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Re: 2003 SRT DD

Post by occasional demons » Thu Jun 20, 2019 10:38 am

Not gloss...

https://www.amazon.com/Dupli-Color%C2%A ... way&sr=8-7

Satin may not be too bad though.
Bill
dblsg wrote:ya'll a bunch of post whores
Seriously people, this is 2019 not 1920.
2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Sat Jun 22, 2019 8:26 pm

So I finally performed a boost leak test. Turns out the pink line had blown off the surge valve. I reattached it and took the car for a quick spin around the block. The car spikes twenty pounds now. I’m not sure what it holds to redline because I ran out of road. I was also too busy saying “holy shit” with my eyes glued to the road. I hope to be able to take it out again when the wife gets home later.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Mon Jun 24, 2019 11:18 am

Well that was short lived. I went out for a late night cruise in the car and popped something carrying coolant under the turbo. I think it's the coolant return line that goes into the block, behind the turbo. I limped the car home on bottled water and let it sit overnight to cool off. The next day, I removed the intake and battery to see if I could get back there. Not really. It's so tight I can't get my hand in there very far at all. It's just as buried from the bottom, too. I'm not sure exactly what I'm going to do about it.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
MyNeonSaysHi
2GN Veteran
Posts: 11666
Joined: Mon May 23, 2005 8:46 pm
Location: Kansas

Re: 2003 SRT DD

Post by MyNeonSaysHi » Mon Jun 24, 2019 3:58 pm

JeremyJ wrote:
Sat Jun 22, 2019 8:26 pm
So I finally performed a boost leak test. Turns out the pink line had blown off the surge valve. I reattached it and took the car for a quick spin around the block. The car spikes twenty pounds now. I’m not sure what it holds to redline because I ran out of road. I was also too busy saying “holy shit” with my eyes glued to the road. I hope to be able to take it out again when the wife gets home later.
So you had nothing attached to the surgevalve. Wow. Glad you finally fixed it. You do another leak test after attaching the pink line? Surprised that was the only thing leaking.

Or it was the oil cooler lines, they tend to get old and crusty. They carry coolant. Yeah I would jack it up, sounds like you can access it better from underneath. Hopefully a simple fix

08 Acura TL-S
05 Neon SRT-4

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Mon Jun 24, 2019 4:29 pm

Seems like it's never a simple fix with me. Always something complicated.

I tested it before and after reattaching the pink line. It wouldn't even hit 15 psi on the gauge before I reattached it, but was creeping up on 20 afterward. It felt like there was a tiny bit of air coming out around the surge valve as well. Has me looking at this:

http://www.modernperformance.com/produc ... d-adapters

I couldn't hear anything else leaking. The charge pipe, both intercooler pipes, and the rest of the vacuum lines seemed good and quiet. It boosted like crazy once that pink line was back on there. The car sure pulls hard at twenty pounds.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

User avatar
JeremyJ
2GN Member
Posts: 821
Joined: Wed May 12, 2004 2:03 am
Location: Kent, Washington

Re: 2003 SRT DD

Post by JeremyJ » Tue Jun 25, 2019 1:01 pm

I poured some water into the system and watched it piss out of the coolant return line, below the turbo. Looks like I have a daunting job ahead of me. I'm going to try to enlist a mechanic buddy of mine to help me out.
02 base -> 05 SRT ACR -> 96 sedan -> 99 R/T coupe -> 02 R/T -> 03 SRT

Image

Post Reply

Return to “Progress/Project Log”