How-To: Install Autostick shifter/ cluster * finally working

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

How-To: Install Autostick shifter/ cluster * finally working

Post by Gnuserup » Sun Jun 05, 2011 11:15 am

Presupposition is the 4-gear ATX 40TE or 41TE and that you have a TCM with that inputs for up- and downshift.

The first step to add Autostick to my 2005 SXT has been to install the Autostick shifter (out of an UK Neon) today

this is the shifter

Image

the knob

Image

how to remove it

Image

disassembled item - you´ll notice on the left the plugs for the (LED ?) - lighting and for the up- and downshift.

Image

originally shifter

Image

no plug for the light (you´ll have to pull that socket out with power) - I cutted the wires and soldered them to the Autostick-light-plug.

Image

plug and socket from the autostick

Image

removed

Image

blank tunnel

Image

the bowdenwire - still fits on both shifters (be careful - or the hooks are breaking :tardbang: )

Image

installed both wires on the autostick shifter (direct fit)

Image

the plug for the up- and downshift function

Image

rearview

Image

bezel installed (lettering on the right as it has been out of an UK neon :lol: )

Image

bracket on

Image

installed my good old LX bezel by that opportunity

Image

so far so good...

it is shifting as usual except there is no position for limiting into the 1st gear - means anything works as you are used to and if I shift into A/S Position the ATX is limited to the third gear. So there should be no mechanically need to get an autostickshifter if you like to add Autostick.

My theory is - if I understood the wiring correctly, that on my 2005 NGC Neon the PCM/TCM is one unit and has on its white plug (C3) on pin 26 the T44 20YL/LB wire for Autostick downshift switch signal (pin 1 on the switch) and on 27 the T5 20LG/LB wire for Autostick upshift signal (pin 2 on the shifter). Both wires should go directly into the plug on the rear of the shifter. That plug should have on its pin 4 the F11 20RD/WT wire Ignition Switch Output (Off-Run-Start) and on 3 Z1 20BK Ground. (See 8W-80-6, 8W-80-53 and 8W-10-11 to 12).
Maybe its enough to give 12V Ignition-Switch-Power into Pin 4, ground #3 and route 1 and 2 to the TCM to get that working.
I will try that out as early as possible, ignoring that the whole wiring on originally with Autostick equipped neons is a bit different (e.g. the fuses).
Last edited by Gnuserup on Fri Dec 30, 2011 6:38 am, edited 5 times in total.

racer12306
Junior Admin
Posts: 16012
Joined: Sun Oct 24, 2004 8:53 pm
Location: Baltimore, MD
Contact:

Post by racer12306 » Sun Jun 05, 2011 11:20 am

Looks great.

Good writeup.
-Frank
Member of Spork Racing
Forum issues: racer12306@2gn.org
Forum Behavior
Support your favorite forum, DONATE!

dsnowsxt
2GN Member
Posts: 114
Joined: Sat Oct 02, 2010 1:20 pm
Location: Jax fl

Post by dsnowsxt » Sat Jun 11, 2011 1:35 am

holy shit i love this write up i want it!
2005 sxt

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jun 11, 2011 3:31 pm

:lol: seems that you have the right date of built, but wait until I electrified it :D

keep your fingers crossed, that it would just function and I won´t cook my PCM :tardbang:

User avatar
Johny
2GN Member
Posts: 1238
Joined: Sat Jun 12, 2010 3:10 pm
Location: Toronto
Contact:

Post by Johny » Sat Jun 11, 2011 4:23 pm

That is sweet man, why do all the euro cars get all the cool stuff :(
Image
www.JohnyR.net - Web development

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jun 11, 2011 4:48 pm

It´s just to keep modding interesting - anyone who has a dodge likes to change it to chrysler and reverse, manuals like to swap to automatic and reverse, non-ABS to ABS and so on :laughing3:

2nd level: keep some things absolutely rare and sell them only directly at the other end of the world :tardbang:

User avatar
Johny
2GN Member
Posts: 1238
Joined: Sat Jun 12, 2010 3:10 pm
Location: Toronto
Contact:

Post by Johny » Sat Jun 11, 2011 5:32 pm

Haha yeah that makes sense, I guess. Did you get the shiftronic working?
Image
www.JohnyR.net - Web development

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jun 11, 2011 5:46 pm

unfortunatelly not for the moment but just because I am out of time - am alone with my two kids this weekend and they charge a minimum of hundred percent attention :lol:

But have bought a plug for the power-outlet and beauty orange, green, violett and some more wires for the work.

So I am planning to wire the plug up as a temporarely setup and try if all is working. If so, I will solder everything as it should.

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sun Jun 12, 2011 7:33 am

Made a little progress today.

I took a cheap power plug and soldered the rd/wt and the black on it to have a chance to check what the A/S-switch is doing.
Then I soldered the cableshoes for the PCM-Plug to have the wires for future use.

Image

Lesson one - don´t use cheap power plugs or have enough fuses with you.
That damn thing has been too cheap - if I assembled it after soldering, it broke into pieces and killed the fuse. :banghead:

Took another and it worked.


It seems that the switch does not give power to the pcm, as I measured 0V between either the up- or the downshiftwire to ground.
But I measured 900 Ohm (is that correct ? Damn - I could not ever memorize to read the multimeter right) only if I upshift or downshift with ignition on from either the up- or the downshiftwire to ground.

Image

Next time I will insert the cableshoes to the PCM-Plug and route the wires to the shifter :thumbup:

***

found something special - http://cgi.ebay.de/Chrysler-Neon-2-0-Au ... 25649489a5

if I had more money ... Nice cluster :D

***

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Mon Jun 13, 2011 1:08 pm

Wired it up today.

Noticed, that the wires are still there :shock:

Image

I think, they will go to the socket at the firewall. I tried to get this out, but without removing the whole dashboard it seems to be a useless job. So I decided to solder my new wires onto the both from the C3 plug.

Image

and routed them through the hole of the hood-bowdenwire to the inside.

Image

I measured 10,5V on both wires, about 13,78 V on the powerwire and ground is still working, but unfortunatelly not the autostick :banghead:
At (D) the ATX is running as usual, on A/S aka (3) it is shifting higher very late, but does not react on + or - .

So maybe it has to be an programming issue - anyone any suggestions ... ?
.
.

User avatar
z3roneo
2GN Member
Posts: 3543
Joined: Mon Jan 31, 2005 12:08 am
Location: Humble,Tx
Contact:

Post by z3roneo » Fri Jun 17, 2011 11:28 am

Very interested on how this will turn out... :thumbup:
2000 2.4L Turbocharged Neon (The Monster)
2005 5.7L Hemi Jeep Grand Cherokee (SRT8 Clone)


Image

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Fri Jul 08, 2011 6:27 am

Lost 3 hours and 20 € today to learn, that there is no option to activate with a DRBIII. It just shows what it is : "4-speed-ATX" and "non-Autostick" :(

He said, it maybe could depend on the different cluster or not at least on the PCM anyway.

So next step is to get hands on that damn cluster.

Anyone ever tried a PT Cruiser Cluster in a neon ? They are pretty easier to find with autostick than the neon-clusters with it.

User avatar
TinyQ
n00b
Posts: 5
Joined: Thu Jul 21, 2011 8:48 am
Location: Belarus

Post by TinyQ » Thu Jul 21, 2011 9:34 am

Hello. I installed in my Neon 2005 SRT-d cluster 4671 813AC (140 MPH with Tach & with Autostick Transmission (Europe)) from UK Neon 2002 and connected two switches to PCM and Autostick works fine.

4671805AE CLUSTER, Instrument Panel, 120 MPH without Tach
4671806AD CLUSTER, Instrument Panel, 120 MPH with Tach
4671808AD CLUSTER, Instrument Panel, 240 KPH without Tach
4671809AD CLUSTER, Instrument Panel, 240 KPH with Tach (Mexico)
4671811AC CLUSTER, Instrument Panel, 240 KPH with Tach & with Autostick Transmission (Europe)
4671812AC CLUSTER, Instrument Panel, 140 MPH with Tach & without Autostick Transmission (Europe)
4671813AC CLUSTER, Instrument Panel, 140 MPH with Tach & with Autostick Transmission (Europe)
4671876AJ CLUSTER, Instrument Panel, 140 MPH with Tach
4671810AD CLUSTER, Instrument Panel, 240 KPH with Tach & without Autostick Transmission Canada

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Thu Jul 21, 2011 10:48 am

so maybe he needs the correct cluster to activate the autostick feature?
dammit - those are really hard to find here!!

occasional demons
Junior Admin
Posts: 19058
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Thu Jul 21, 2011 12:00 pm

Part number 4671811AC was superceded by part number 4671811AH. $800.00

Part number 4671813AC was superceded by part number 4671813AH $762.00
Yeah, for a new one, you would really want it hard core. :lol:
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Danteneon
Former Moderator
Posts: 9591
Joined: Thu Dec 20, 2007 5:13 pm
Location: Manassas, VA

Post by Danteneon » Thu Jul 21, 2011 12:24 pm

I think you will need the cluster for the autostick to work. I do remember when looking up replacement clusters it asks if the car is autostick or not (and not just Neons).

Hell, there was an autostick option for the Caravans. And they have column shift :shock:
If I could just figure out how to meld the Outback and the Neon into one car...

Image

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Thu Jul 21, 2011 1:18 pm

hey - great to hear that. That´s what the mechanic siad he thinks.
I thought about a PT-Cruiser-cluster, but has anyone tried to get such one functioning ?
If nothing else helps, I think I have to make a 1300 km journey to visit an autostick-neon-owner and will have to persuade him to change the clusters for a try.

occasional demons
Junior Admin
Posts: 19058
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Thu Jul 21, 2011 1:46 pm

I wonder if the circuit board from the PT would swap into a neon cluster. This would be easier than trying to swap the whole cluster.(As long as the speedometers were the same mph/kmh.)

The only other problem may be, if the Auto Stick cluster has indicators for the gears, and does it need them?
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Thu Jul 21, 2011 1:51 pm

The PT´s here have more often the autostick than a neon has - so on ebay there are sometimes that clusters to find.
But anyway - at least I have to find a neon-autostick-cluster.

Hasn´t there been a red-dot-issue when changing the cluster to a different ?

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jul 23, 2011 4:34 am

ok - have compared the pinout of a neon and a PT cluster. Except the main-plug seems to be the same, the pinouts are totally different and the PT cluster has a second cluster-plug. So it seems, there would be no comfortable way to use a PT cluster.

add: nevertheless - just studied the pinouts more intensive and think, it´s just the pinout-thing - most of the wires are exactly the same and the Autostickissue on PT´s must be the same, as they have a different cluster especially with the PRND-Indicator, too. So it must be possible to use a PT-Cluster in a Neon and reverse, if willing to totally change the pinouts of the cluster plug or making an adapter ... I think both clusters are communicating with the pcm by the D25 20VT/YL - PCI-Bus.

Anyone any suggestions ?

btw - I know the clusters are mechanically different, but just to try if the autostick-function works ....
Last edited by Gnuserup on Sat Jul 23, 2011 7:09 am, edited 1 time in total.

occasional demons
Junior Admin
Posts: 19058
Joined: Thu May 03, 2007 12:14 pm
Location: Ashland Ohio

Post by occasional demons » Sat Jul 23, 2011 7:02 am

If the connector plugs are the same, the wires could be moved around in the neon female plug. But figuring out if the second plug uses circuits that are in the neon main plug would be critical, or if the second plug is just for the gear select indicators. (My guess)

Can you post the PT pin outs, if you have an illustration?
Bill
dblsg wrote:ya'll a bunch of post whores
epic

2001 Neon ES MTX with '02 R/T PCM
Help support 2GN!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Jul 23, 2011 7:12 am

yeah - our posts just crossed...

Have a wiring for the PT Cluster and found

C1 :

1) Z1 18BK ** GROUND
2) Z2 20BK/LG ** GROUND

3) L7 18BK/YL ** HEADLAMP SWITCH OUTPUT
4) M1 20PK ** FUSED B(+)
5) .
6) .
7) M2 20YL ** COURTESY LAMPS DRIVER
8( .
9) G75 20TN (LHD) // G74 20TN/RD (RHD) ** LEFT (Right) FRONT DOOR AJAR SWITCH SENSE
10) L161 18LG/OR (LHD) ** LEFT TURN SIGNAL (OUT)
11) L61 18LG ** LEFT TURN SIGNAL (IN)
12) L160 18TN/RD (LHD) ** RIGHT TURN SIGNAL (OUT)
13) L60 18TN ** RIGHT TURN SIGNAL (IN)
14) G5 20DB/WT (VTSS) // G5 20DB/BK (OTHER) ** FUSED IGNITION SWITCH OUTPUT (RUN-START)
15) F11 20RD/WT (AUTOSTICK) ** IGNITION SWITCH OUTPUT (UNLOCK-RUN-START)
16) .
17) L4 16VT/WT ** DIMMER SWITCH LOW BEAM OUTPUT
18( L3 16RD/OR ** DIMMER SWITCH HIGH BEAM OUTPUT
19) G26 20LB ** KEY-IN IGNITION SWITCH SENSE
20) G10 20LG/RD ** SEAT BELT SWITCH SENSE
21) G11 20WT/BK ** RED BRAKE WARNING INDICATOR DRIVER
22) E2 20OR ** PANEL LAMPS DRIVER
23) M9 20DB/OR ** PASSENGER DOOR AJAR/RKE SENSE
24) G78 20TN/BK ** LIFTGATE AJAR SWITCH SENSE
25) D24 20WT/DG ** FLASH PROGRAM ENABLE
26) D25 20VT/YL ** PCI BUS

the C2-Plug (10 pin) on PT is always for

1) L39 18LB (FOG LAMPS) ** FOG LAMP SWITCH OUTPUT
2) G69 20BK/OR (RKE) ** VTSS INDICATOR DRIVER
3) .
4) .
5) .
6) L38 18BR/WT (REAR FOG LAMPS) ** REAR FOG LAMP SWITCH OUTPUT
7) E19 20RD ** PANEL LAMPS DIMMER SIGNAL
8( L1 20VT/BK (MTX) ** BACK-UP LAMP SWITCH OUTPUT
9) G4 20DB ** FUEL LEVEL SENSOR SIGNAL
10).

You see, the circuits and colours are mostly identical :)

So what do you think - either turn around any pins or what the hell would the pcm do if two clusters are installed at the same time (one Neon-Cluster as usual and the PT-cluster just power, ground and pci-bus for the autostick-present-message [like kind of an autostickdongle]...)

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Sun Jul 24, 2011 8:49 am

i could make you an adapter with a female connector (find it in the door harness) and male pt cruiser harnes for a direct plug-in.
no problem for me!

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Fri Jul 29, 2011 9:43 am

A custom-PT-Cluster-fitting dashboard would be appreciated most :lol:

I thought a bit about the cluster <-> PCM - relation (while I have been searching for a neon-autostick-cluster without any result).
As there is only one wire at the cluster called PCI Bus (on PIN2 ) - might that be receiving information from the PCM or is it transferring or maybe both ?? Anyone knows ??
Where the hell should the pcm know, what kind of cluster is present ?

Jenni
2GN Member
Posts: 2499
Joined: Tue Aug 23, 2005 1:33 pm
Location: Berlin, Germany

Post by Jenni » Fri Jul 29, 2011 11:24 am

pt cruiser harness and pcm is the same - so should be the bus also

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Fri Jul 29, 2011 12:39 pm

figured out meanwhile that the pci-bus should communicate bi-directional respectively multi-directional trough just this one wire
Now I just need a willing seller and a affordable PT Cluster and will try that funny stuff to get to work. If it will, you could start thinking about a custom dashboard :lol:

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Sat Aug 13, 2011 4:27 pm

We inspected a 2002 SE Autostick with 65000 km today, but at least did not buy her.
It was an very interesting and promising Neon and the donor of the ATX I have laying around. My friend was close to buy her but as we took her to a testdrive, we noticed that the engine was very low on oil and sounded worse. She felt tired when accelerating especially about 100 km/h and more so we thought there has to be something wrong with the engine anyhow.

Nethertheless I learned something new of the work of the autostick on a neon.
With ignition on and engine running you have a gear indicator in the cluster (D N R a.s.o), with shifter in A/S-Mode you have the gear-number selected there (3, 2 or 1 - but never 4 - for sure).
So what I have always been asking myself how that autostickmode is working - the answer is - shift in D and you´ll have all 4 gears controlled by the TCM, shift in A/S (which is the (3)- Position usually), you could choose by shifting + or - from 1 to 3, but not 4. By shifting +/- with brakes on I felt the trany working.

User avatar
TinyQ
n00b
Posts: 5
Joined: Thu Jul 21, 2011 8:48 am
Location: Belarus

Post by TinyQ » Mon Aug 15, 2011 2:47 am

4 gear is switched on only at a speed of more than 24km/h

User avatar
Gnuserup
2GN Member
Posts: 661
Joined: Sun Jun 28, 2009 3:06 pm
Location: Germany

Post by Gnuserup » Mon Aug 15, 2011 1:32 pm

Aha - good to know.
That I haven´t noticed while driving.
Will see anyway if I sometimes could get a cluster.

User avatar
TinyQ
n00b
Posts: 5
Joined: Thu Jul 21, 2011 8:48 am
Location: Belarus

Post by TinyQ » Tue Aug 16, 2011 3:23 am

Wolfsburg as far away from you?

Post Reply

Return to “HT Electrical”